Takeuchi Battery size

Discussion in 'Heavy Equipment & Pavement' started by AWJ Services, Jan 26, 2013.

  1. AWJ Services

    AWJ Services LawnSite Platinum Member
    from Ga
    Posts: 4,276

    Does anyone no what size battery is in a TL140?

    16 inches long, 8 inches tall, 7 inches wide. Approxmiatley
     
  2. muddywater

    muddywater LawnSite Bronze Member
    Posts: 1,813

    Have you checked the water? Mine got low and i refilled and it worked for a while lomger.
     
  3. turboawd

    turboawd LawnSite Member
    from midwest
    Posts: 231

    not sure why takeuchi has theses batteries with the water ports.
    i ended up just going to an interstate battery store and getting a sealed battery of similar size.
     
  4. AWJ Services

    AWJ Services LawnSite Platinum Member
    from Ga
    Posts: 4,276

    Yes for the third time.LOL That sucker is like the energizer bunny. It is a 2006 model and still the original battery.
     
  5. AWJ Services

    AWJ Services LawnSite Platinum Member
    from Ga
    Posts: 4,276

    I was going to do that Monday but the battery place is 40 miles away and I was hoping too know what size it was too make sure they did not give me the wrong battery
     
  6. KTM

    KTM LawnSite Senior Member
    Posts: 492

    I replaced mine with a interstate that the local CASE AG dealer had in stock. The parts guy remembered selling the model to a guy with a few Gehl CTL70's. I wanted the TK replacement but it was big$$$. I can get you the model# but won't be back around my machine until Tuesday. I did find out one thing with replacing the battery on mine, you have to tighten the negtive cable extremely tight.
     
  7. Dirtman2007

    Dirtman2007 LawnSite Platinum Member
    Posts: 4,366

    have fun getting the SOB out. That was a royal pain my in 150
     
  8. AWJ Services

    AWJ Services LawnSite Platinum Member
    from Ga
    Posts: 4,276

    I took it out yesterday and it was fun.LOL
     
  9. AWJ Services

    AWJ Services LawnSite Platinum Member
    from Ga
    Posts: 4,276

    I actually just took the bolt off the negative cable where it fastens too the chassis and left it on the post.
     

Share This Page