This normal?

Discussion in 'Heavy Equipment & Pavement' started by cat2, Jun 29, 2007.

  1. cat2

    cat2 LawnSite Senior Member
    from Mi
    Posts: 891

    HI. Just wondering if this is normal or not. On my bobcat I turn the key on everything lights up like it should. Then when I turn the key to start it the glow plug light comes on then when I let off of the key light goes off.:confused: Even if it just ran and shut off for 5 mins it will do the same thing.
     
  2. tallrick

    tallrick LawnSite Senior Member
    Posts: 682

    What year and model Bobcat? Many older units have a manual start configuration where you can glow as long as you want, but later machines had timers. The newest Bobcats have a countdown timer. I have seen machines where the glow plug light comes on while running the starter, but no voltage was present to the glow plugs and also the plugs being activated on start. As long as your glow plugs aren't staying on you're fine. One Bobcat I had repaired had a bad glow plug relay and the owner used starting fluid to get it running. The flywheel teeth had been damaged from the kick each time the engine started.
     
  3. cat2

    cat2 LawnSite Senior Member
    from Mi
    Posts: 891

    Its a 2007 s-160. thanks for the reply.
     
  4. turboawd

    turboawd LawnSite Member
    from midwest
    Posts: 236

    some machines activate the glow plugs between the "on" and "start" positions of the key switch. not sure if bobcat does this.
     
  5. tallrick

    tallrick LawnSite Senior Member
    Posts: 682

    Sorry it took so long, I asked a friend with a rental yard and he says they the S130 loaders he has do that as well. Seems like normal behavior for the machines.
     
  6. cat2

    cat2 LawnSite Senior Member
    from Mi
    Posts: 891



    Thanks alot. If theres anything I can do for you just yell:) :)
     

Share This Page