time to change tl 130 tracks

Discussion in 'Heavy Equipment & Pavement' started by SunriseGardens, Feb 23, 2013.

  1. AintNoFun

    AintNoFun LawnSite Bronze Member
    Posts: 1,807

    not to hijack the thread but since were on tl130s.. the fan just broke on ours, dealer ordered me a new one and my mechanic slapped on the new one. which was does the fan blow out thru the radiator out the back door or sucking in thru the back door blowing towards the motor?

    our machine is now sucking in thru the back door but I thought I remembered the air blowing out? not sure...:confused:
     
  2. AWJ Services

    AWJ Services LawnSite Platinum Member
    from Ga
    Posts: 4,276

    Blows out.
     
  3. AintNoFun

    AintNoFun LawnSite Bronze Member
    Posts: 1,807

    ty, that's what I thought.. I knew we got the wrong fan....
     
  4. alldayrj

    alldayrj LawnSite Gold Member
    Posts: 3,768

    Might be as simple as switching the wires
     
  5. Nelson M Martin

    Nelson M Martin LawnSite Member
    from Ontario
    Posts: 192

    If the fan department is build the same as the Gehl machines then I believe the fan is direct engine mounted....But as long as enough air passes thru the rad the engine should cool.
    the only thing that might make a difference is the arrangement of the oil cooler rad and the engine cooling rad. for example originally oil cooler was cooled first before engine or vise versa
     
  6. turboawd

    turboawd LawnSite Member
    from midwest
    Posts: 236

    could it be as simple as flipping the blade around?
     
  7. Nelson M Martin

    Nelson M Martin LawnSite Member
    from Ontario
    Posts: 192

    No that well certainly not help for direction of air flow
     
  8. AintNoFun

    AintNoFun LawnSite Bronze Member
    Posts: 1,807

    has like a spacer on it so it only goes one way..

    was a hot day here today and my operator noticed with the air on the cab was still pretty hot, was never like that.. so its def the wrong fan!
     
  9. excav8ter

    excav8ter LawnSite Member
    Posts: 201

    Well....my solideal tracks finally gave out. Just ordered another set from Joe Boggs @ www.tracksandtires.com

    The rubber is in good shape, but it wore the steel cross bars, and ripped the track down the center. I think I ended up with around 1700 hours of pretty hard use.
    Posted via Mobile Device
     
  10. swanny

    swanny LawnSite Senior Member
    Posts: 656

    Anyone ever experienced this: TL120 with 180ish hrs. OEM tracks?

    [​IMG][/URL][/IMG]
     

Share This Page