1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Toro 283L Need Help

Discussion in 'Homeowner Assistance Forum' started by Stan MI, Mar 22, 2008.

  1. Stan MI

    Stan MI LawnSite Member
    from MI
    Posts: 100

    This mower has been flawless for me, owned since new. Took it out just to let it run for a while because it had been sitting for a couple of months. Noticed the temperature gauge in the red after it ran a while. Turned it off and let it cool down. Opened the radiator cap and it looks like it has been dry for quite a while. Filled to run off with a 50/50 mix of antifreeze and distilled water. Restarted and now the gauge rises to what I would call higher than normal temp and falls just to the bottom of the green zone and repeats this process over and over. Seems OK, but now the fan never comes on (it did in the past). Is it possible I have just had low coolant for a long (read as I haven't checked it often enough) time and this is normal operation or would a visit to the mower doctor be in order.
  2. Stan MI

    Stan MI LawnSite Member
    from MI
    Posts: 100

    I just posted this in the repair section. Didn't see it before.
  3. kubotab7200

    kubotab7200 LawnSite Member
    from Newkirk
    Posts: 80

    sounds like the thermostat my be sticking, my kubota tractor did that last year and thats all that was wrong with it. i replaced it with a new one and changed the coolant and it has operated fine since then, hope this helps

Share This Page