1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community on the Franchising Forum.

    Dismiss Notice

Toro 6500 problem

Discussion in 'Mechanic and Repair' started by craigie77, May 13, 2013.

  1. craigie77

    craigie77 LawnSite Member
    Posts: 2

    I have a recurring problem with my Toro 6500. The mower runs fine for a while then all of a sudden loses power and splutters for a few seconds, it then picks up again and runs fine until the next splutter. This problem occurs when in transport and when there is load on the engine. Fuel and air filters have been changed and a new fuel pump fitted. I have also bypassed the seat switch to check if that is the problem.

    Has anyone experienced similar problems with this machine?
    Any advice would be much appreciated.
     
  2. herler

    herler LawnSite Fanatic
    Posts: 5,145

    I suspect a partial clog in the carburetor fuel float and bowl department.

    That's likely where the problem is, fuel is getting to the carburetor, but it's not getting past the bowl.
    Might need a whole new carburetor.

    But I would try a thorough cleaning first.
    Especially the jet.

    Then make sure the float is moving freely as well.
     
  3. craigie77

    craigie77 LawnSite Member
    Posts: 2

    Thanks for the reply herler.

    I should have mentioned in the opening post, this is a diesel engine. Toro 6500-D.
     

Share This Page