1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

toro 724-z hydraulic / Charge

Discussion in 'Mechanic and Repair' started by ccof1969, Jul 5, 2008.

  1. ccof1969

    ccof1969 LawnSite Member
    Posts: 2

    I have two problems, I just bought a Toro 724-z a few months ago and I was told it won't fully charge and I would need to charge the battery about once a month.

    Problem 1) It wont charge at all, I bought a new battery and still the same thing. After I charge it I can use it for about 45min-hour before it dies or if I turn the blades off or turn the mower off I will need to recharge it. any suggestions?

    Problem 2) After a few week I noticed that the right side after about 30 min would lose some power, Now after about 15 mins on hills it loses more until it would move. I can continue to cut mostly using the left and it will start to have power but not much, I was told to drain the hydraulic fluid and re place it & still no change. Any suggestions?

    I was given no manuals but have downloaded some. I know I was taken on this so I just need to try to fix it. Thanks for any help.

    S DIAMOND LawnSite Member
    from South
    Posts: 108

    Right, this is related to your charging circuit and one or more of its components. Could be a damaged stator, rectifier, poor or damaged connections or a blown fuse. If you are handy with a (decent) multi meter, the task will be much easier.

    could be several things involved here also.

    Start by posting your model number to help narrow down some suggestions.
  3. ccof1969

    ccof1969 LawnSite Member
    Posts: 2

    It is a Toro ProLine 724-Z model 74140 Serial #690209 & the engine is p/n 941814. Thanks for your help.

Share This Page