Toro safety switch problem

Discussion in 'Mechanic and Repair' started by Atlantic Lawn, Sep 9, 2007.

  1. Atlantic Lawn

    Atlantic Lawn LawnSite Senior Member
    Male, from Outer Banks NC
    Posts: 940

    Toro Z Master, an 04. It started cutting off while mowing, got it back on the trailer and checked the safety switches, thought it was the seat safety switch.Starts and runs fine but when you release the parking brake lever it shuts off. Swapped out the seat switch, still cuts off, swapped out the parking lever safety switch and still shuts down when you release the lever. Put a new pto switch in and still no luck. With parking brake on, pull in either steering lever and motor shuts down as it should.Checked and cleaned all the connectors . Not too sure what else I can do, at least it's on the trailer . I'm leaning toward a problem somewhere in the seat safety switch wires. ... Any thoughts ????
     
  2. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    Some units have a little switch inside the seat switch plug connector (a little button sticking up between the two female spade connectors).

    Check into this but you can't just cut the wires and put them on the seat switch, You must replace the plug connector.
     
  3. Atlantic Lawn

    Atlantic Lawn LawnSite Senior Member
    Male, from Outer Banks NC
    Posts: 940

    I'll look at that in the morning, finally getting a little rain here from tropical storm Gabrielle.This one really has got me stumped.....Thanks
     
  4. Atlantic Lawn

    Atlantic Lawn LawnSite Senior Member
    Male, from Outer Banks NC
    Posts: 940

    Problem Solved ! The mercury switch used in case of rollover was bad.....who would have figured, anyway this seems to be a known problem with toro and others....bypass the switch and just use the seat safety switch. They apparently don't sell the mercury switches anymore see'in as how mercury is so toxic to the human body !!! Kinda makes me think about all those silver/mercury fillings the dentists used in the 50's,60's and 70's....oh well it works now and we cut with it today.
     
  5. leeker

    leeker LawnSite Member
    Posts: 51

    this is my first time on this site. here is goes. i am having the same problem with a toro mower myself. is this mercury switch mounted to the frame under the seat that you replaced. i have power going to this mercury switch while the unit is running in the park position but nothing to the seat switch from it. i have the same problems with it killing the engine when you release the brake or steering arms.. where did you by pass it at.
    thanks for listening
     
  6. peak2p2000

    peak2p2000 LawnSite Member
    Posts: 15

    hey guy there was a recall done on the mercury rollover switch units.we jusy got our taken care of . our dealer gave us the roll bar assymbly that toro used to fix this issue in order to satisfy osha. they didnt charge us for the roll bar.
     
  7. peak2p2000

    peak2p2000 LawnSite Member
    Posts: 15

    the problem was the danged switches never even worked in the first place.
     
  8. leeker

    leeker LawnSite Member
    Posts: 51

    peak2p2000

    i replaced that switch shorly after i posted the thread and it took care of the problem.

    thanks for the reply
     

Share This Page