toro zmaster problem

Discussion in 'Mechanic and Repair' started by clayslandscape, Jul 19, 2013.

  1. clayslandscape

    clayslandscape LawnSite Senior Member
    Posts: 457

    I have a 48" toro zmaster that has 490 hrs on it. I was cutting this morning and all of a sudden I could not cut thru hardly anything without bogging down. If I backed up, the engine regained its Rpm's but would decrease to near halt by the time I got back to grass. The guy over the phone said I may have thrown a rod or blew piston. Compression is 125 on outside and 15 inside so he says when he tested it.

    It has a 20hp kawasaki commercial engine.

    Not sure what to do. Is the mower still under warranty ? Have called my nearest toro dealer but can never get answer. The next closest is 60 miles.
     
  2. JCLawn and more

    JCLawn and more LawnSite Fanatic
    from MI
    Posts: 5,206

    My guess is a clutch bearing or engine bearing. Does it have power without the pto on?
     
  3. piston slapper

    piston slapper LawnSite Platinum Member
    Posts: 4,240

    Sounds like a pushrod came loose...
    Remove the valve cover and put it back on...
    Adjust the valves....should have already been done twice by 490 hours..
    Ya gotta do the maintenance...
     
  4. ricky86

    ricky86 LawnSite Bronze Member
    Posts: 1,772

    490 hrs. I'm not sure but it might be time to grease it too. :laugh:
     
  5. clayslandscape

    clayslandscape LawnSite Senior Member
    Posts: 457

    It has had it's normal maintenance done. You think it is something as easy as a push rod?
     
  6. piston slapper

    piston slapper LawnSite Platinum Member
    Posts: 4,240

    What i think is unimportant....
    Take a look for yourself....
    The rod aint broke...ya still have 15 psi...
     
  7. herler

    herler LawnSite Fanatic
    Posts: 5,144

    I am going to agree with Piston Slapper because I done been the rounds with these Kohler /Torro people and I ended up doing exactly what he just said, sorry ass warranty coverage, more like no warranty at all, I guess we could get mad as hell but what's the use, just pull off the valve cover and take a look, fix anything loose or broken in there.

    Oh, and remember Toro and Kohler for future reference, yeah buddy, can't say if other brands will treat us better but I bought a Scag this time.
     
  8. BigFish

    BigFish LawnSite Gold Member
    Posts: 3,170

    You do realize the guy was talkin' bout a KAWASAKI motor, right??????



    And by the way, clay..., it's toast. Seen that problem with a chitload of Kaws.
    Oddly enough, right around the 500-700 hr range, they would appear to seize a valve, then crack/hole a piston , and bend the pushrod/s.
    Sometimes though, the valves were still free on inspection/ cooldown.
    At any rate, Kaw. replaced em with no hassels, not even photos.
     
  9. clayslandscape

    clayslandscape LawnSite Senior Member
    Posts: 457

    How would I go about contacting kawasaki and making sure this gets taken care of?
     
  10. BigFish

    BigFish LawnSite Gold Member
    Posts: 3,170

    You're prolly gonna have to let a Kawasaki Power Products dealer handle it.
    I don't think you have to go thru Toro, since it's the engine that's giving you problems.

    The Kaw site should help you some: http://kawpower.com/
     

Share This Page