Trailer Lighting Question

Discussion in 'Trucks and Trailers' started by Mack77, Aug 17, 2008.

  1. Mack77

    Mack77 LawnSite Member
    from NJ
    Posts: 208

    Hi Guys,

    I'm currently working on my trailer (new lights, checking the wires, etc). Everything works great, brake lights, turn signals, hazards. Everything except the night time running lights. Any ideas?

    It's not the truck, because i attached another trailer to test this out, and the night time running lights worked...

    Thanks!
     
  2. ffemtmcd

    ffemtmcd LawnSite Senior Member
    Posts: 532

    HHHmmmm - not sure - do the taillights work with the running lights on?? if not check for a cut wire or something like it - can't imagine what else it would be.
     
  3. Mack77

    Mack77 LawnSite Member
    from NJ
    Posts: 208

    I've done a few things so far...

    Replaced both lights. (The kit, housing, lights, wires) Right side and left side.
    Replaced the plug that plugs into the truck.
    Checked the white ground wire, seems to be in good condition.

    I'm stumped!
     
  4. ffemtmcd

    ffemtmcd LawnSite Senior Member
    Posts: 532

    It's gotta be the green/brown, yellow/brown wire somewhere - I think thats the wire for the "running lights"
     
  5. Mack77

    Mack77 LawnSite Member
    from NJ
    Posts: 208

    So would you say there's a cut wire somewhere, or a bad ground? I think i'll just pull all the wires out and inspect...couldn't hurt.
     
  6. ffemtmcd

    ffemtmcd LawnSite Senior Member
    Posts: 532

    well, if none of the lights worked - I would go with ground - but since the brake lights work it's gotta be the running light wire - let me know how it turns out
     
  7. Mack77

    Mack77 LawnSite Member
    from NJ
    Posts: 208

    Trailer was PERFECT...the trucks I was testing it on had two bad fuses. Can you believe that; TWO exact same blown fuses in two separate trucks.

    So check those fuses guys...save yourself a few hours time!!!
     
  8. Kennedy Landscaping

    Kennedy Landscaping LawnSite Fanatic
    Posts: 5,599

    Is it a Carry-On Trailer? Thats what I have and one week a turn signal wouldn't work, the next a clearance light, and so on. I got fed up with it and rewired the whole thing myself and put on all L.E.D. tail lights and clearance lights and all that good stuff. Also converted the 4-pin to a seven since that's what the trucks all have.
     

Share This Page