Transmission?

Discussion in 'Trucks and Trailers' started by mike lane lawn care, Sep 21, 2006.

  1. mike lane lawn care

    mike lane lawn care LawnSite Bronze Member
    Posts: 1,707

    okay, my 2000 chevy astro (automatic trans) has 164,000 miles on it. when i tow using the tow/haul mode and put the gear selector in "3" as per the manual, then on the highway i put it into "D" and leave tow/haul mode on, also per the manual. when i step on the gas when towing, after coasting, like going down hill or on a low speed road, the engine rev's a bit, almost like it was in neutral. Then after a second it catches, it goes into gear, but the engine revs pretty high before shifting and can have hard shifts going uphill or at 50MPH. i checked the trans fluid last week and it was way low, so i have been slowly adding some over the past few days, and it is now in the acceptable range. but i don't thing that the shifting is directly related to the low fluid level, as other's say their chevy's with tow/haul mode do this.

    it never does this when just driving, is there someting to be concerned about?
     
  2. mike lane lawn care

    mike lane lawn care LawnSite Bronze Member
    Posts: 1,707

    anyone?...
     
  3. elshauno

    elshauno LawnSite Member
    Posts: 182

    Well its low, thats a start. Hows the color is it pink? Do you know if the transmission fluid has been changed regularly? Have you installed a large transmission cooler? Overheating and infrequent changes or never being changed all can kill the tranny.
     
  4. mike lane lawn care

    mike lane lawn care LawnSite Bronze Member
    Posts: 1,707

    i don't know what it's had for changes, but it has been taken care of by a full time mechanic so i can assume that it has had a few changes. i am sending it in soon anyway for a fluid flush and filter change. the color is pink, and i put in some fluid that helps stop leaks(not that there is one, just a precauton) there is no transmission cooler, how would i go about installing one? i can't see any of the engine parts in the van, so work is hard to do.

    thanks for the reply
     
  5. mike lane lawn care

    mike lane lawn care LawnSite Bronze Member
    Posts: 1,707

    nobody here knows about transmissions?
     
  6. mike lane lawn care

    mike lane lawn care LawnSite Bronze Member
    Posts: 1,707

    let's try this one more time, shall we.
    BUMP!
     
  7. Dirty Water

    Dirty Water LawnSite Fanatic
    Posts: 6,794

    When you checked the fluid level, had you driven enough to heat it up first?

    It sounds like its slipping between gears. The transmission was the weakpoint of that astro.

    Just FYI, don't use STopLeak type products. They gum things up. Especially the Radiator ones.
     
  8. mike lane lawn care

    mike lane lawn care LawnSite Bronze Member
    Posts: 1,707

    i had driven with the trailer about 20 miles, so it should have been heated up enough. thatnks for the info on the stopleak products, i was just about to put it in the radiator as a preventative measure/
     

Share This Page