trimmer help!

Discussion in 'Lawn Mowing' started by Josh18, Jun 17, 2004.

  1. Josh18

    Josh18 LawnSite Member
    from AL
    Posts: 64

    I can't believe I did this but I ran two tanks of straight gasoline in my husqvarna(sp?) trimmer. I ALWAYS put the oil in the can then put the gas in it. For some reason I didnt do that last time. Anyways, after the trimmer wouldn't idle at all, I figured out the problem. So I drained all the gas out of the trimmer and the can and put some new gas and oil in. After running the trimmer for a while afterwards, it seems to be running good as new. Is the trimmer going to last or is there a good chance something else is messed up?
     
  2. BladesAway

    BladesAway LawnSite Member
    from Ok
    Posts: 74

    If it didn't lock up chances are it will be ok. Altho you my have shortened its life a little. I wouldn't worry about it run it till it quits.
     
  3. mkwl

    mkwl LawnSite Bronze Member
    Posts: 1,701

    You probably damaged the cylinder lining and definitely shortened the trimmer's life. Mark your gas can so you don't do it again!
     
  4. locutus

    locutus LawnSite Bronze Member
    from NC
    Posts: 1,266

    I'm surprised it didn't lock up. Are you absolutley sure you didn't add oil or did the idle problem make you THINK you didn't add oil?
     
  5. Josh18

    Josh18 LawnSite Member
    from AL
    Posts: 64

    I am about 95% sure i didnt add oil. When I was filling the trimmer up, the gas looked very clear and that's when it hit me. It seems to be running perfect now. Hopefully it will stay that way.
     
  6. locutus

    locutus LawnSite Bronze Member
    from NC
    Posts: 1,266

    You may have dodged that bullet, but I dont know how. Maybe you were nice to a piece of 2-cycle equipment in a past life.
     
  7. Grass_Nerd

    Grass_Nerd LawnSite Member
    Posts: 49

    You ran 2 tanks of straight gas? You caught it the first time then... did it again?
     
  8. Josh18

    Josh18 LawnSite Member
    from AL
    Posts: 64

    No the first time I didnt pay attention to the gas when I was pouring it in. The second time, after the trimmer kept messing up, I noticed it.
     

Share This Page