Trouble with the Hydro ?

Discussion in 'Mechanic and Repair' started by grassworks, Feb 1, 2003.

  1. grassworks

    grassworks LawnSite Member
    Posts: 134

    Well .... I purchased a used Scag 52 ssZ ztr and had it shipped to me. I was told it had been rebuilt from engine to hydro's. After a little coaxing and draining old gas and priming it , I got it started and was all excited. I jumped on... and low and behold the left power control had NOTHING. The Right side is fine , but the left does not respond. Does anyone have any suggestions as to where to start or is this beyond basic mechanic's 101. I have only mostly belt drive and gear drive machines , so I have yet to repair any hydro pump problems. I'm hoping this is somthing minor but fear it is maijor repair. Any help would or ideas are appreciated..... thanks
     
  2. bob

    bob LawnSite Platinum Member
    from DE
    Posts: 4,254

    My GH hs something called "dump valves". What these do is allow you to push the mower without harming the hydros, sorta like putting an automatic transmisson of a car into neutral. Check to see if you mower has these, the left side may be engaged ,if so.
     
  3. grassworks

    grassworks LawnSite Member
    Posts: 134

    MANY THANKS BOB !!

    I went out and checked to see if I could find the dump valves and lo and behold the left side had been tripped and was down. I noticed the right side ( valve) in an earlier inspection but did not know there was a matching valve ( just not visible). Thanks A million ! ol'Scag is looking good now. I love it when I Learnsomething new . Thanks Again Bob-- I was really frustrated , now I will sleep better tonight.
     
  4. bob

    bob LawnSite Platinum Member
    from DE
    Posts: 4,254

    Your welcome, glad I helped!:blob3:
     

Share This Page