Truck problem....need help.

Discussion in 'Trucks and Trailers' started by proenterprises, Jan 17, 2005.

  1. proenterprises

    proenterprises LawnSite Silver Member
    Posts: 2,297

    Okay, so this morning im driving on the highway, and all of a sudden my check engine light comes on and my speedometer drops down to zero. Truck does not stall or anything, but I pull over. First thing I check is the oil, and it is pretty low. I add a quart and the level seems fine.

    I continue on the rest of my journey, truck seems to run fine, but the check engine light is still on. Also, the speedometer still stays at zero and the odometer has stopped ticking.

    What is the problem. I am going to take it by AUTOZONE and have them run the diagnostic test.

    ANYONE have an idea. Its a 1994 Nissan XE pickup.
     
  2. Smalltimer1

    Smalltimer1 LawnSite Bronze Member
    Posts: 1,223

    Sounds like 2 separate problems to me.

    First it sounds as if your speedo cable broke, therefore knocking out your speedo and odometer.

    Second the check engine light comes on if your oxygen sensor goes bad, or if some other sensor such as your cam position sensor (if equipped). The computer will kick out some codes to help you locate the problem.
     
  3. Gautreaux's LNG

    Gautreaux's LNG LawnSite Senior Member
    Posts: 379

    Had this problem before. you have 2 speed sensors on your vehicle. hi and low probally one of those. Wifes van had one in the tranny, cost 800.00 to repair the one in the tranny.
     

Share This Page