Update Echo Pb413

Discussion in 'Lawn Mowing' started by milsaps118, Jul 8, 2006.

  1. milsaps118

    milsaps118 LawnSite Senior Member
    Posts: 559

    Haven't been on LS in a while but I thought that I would update you guys who read and replied to my original post about this blower. I finally got my blower back about two weeks ago. They replaced the carb and now the thing runs like a champ. It was at the dealer for 4wks. One thing I learned, DON'T BUY A C.A.R.B. MODEL!!!!!!!!!:hammerhead: :hammerhead: :nono: :nono:
     
  2. TheLawnBarber

    TheLawnBarber LawnSite Senior Member
    Posts: 539

    I've had my pb-413 for 2/1/2 years no problems at all!!!!!! How long have you had your's? Great blower for the price.
     
  3. ThirdDay

    ThirdDay LawnSite Senior Member
    Posts: 442

    There is nothing wrong with "CARB" models. You had a bad one for some reason but they generally run great!
     
  4. milsaps118

    milsaps118 LawnSite Senior Member
    Posts: 559

    I had that POS for a week, brand new out of the box and it went to the dealer and sat for a month. I like it though it is a good blower for the $$$, I call everything a POS if it doesn't run right.:dizzy: :dizzy: :dizzy: :rolleyes:
     
  5. ThirdDay

    ThirdDay LawnSite Senior Member
    Posts: 442

    It wouldn't have sat at the dealer for a month if you would have bought it from him. They take care of their own customers first...it's only common sense.
     
  6. milsaps118

    milsaps118 LawnSite Senior Member
    Posts: 559

    Regardless if I bought that blower from them or not, I dropped $20K cash with that dealer two years ago and have been a loyal customer of theres for the last 5 years, all the guys in there know me. It should have been done sooner. (they did offer me a loner)
     

Share This Page