WALKER 20 HP Won't shut off with key(help)

Discussion in 'Mechanic and Repair' started by trull, Jun 15, 2007.

  1. trull

    trull LawnSite Member
    from n.c.
    Posts: 8

    I just bought a walker MT,however the guy I bought it from said he just puts it to idle and usees the chock to make it quit running...
    I have started it up and once or twice the switch has stopped it.However it wasn't running at high speed...any help...
    I don't know if this is associated with it not shutting off,,,but the oil and temp lights or alarm does not work??
    Thanks
     
  2. carcrz

    carcrz LawnSite Silver Member
    Posts: 2,085

    you need a new switch.
     
  3. trull

    trull LawnSite Member
    from n.c.
    Posts: 8

    Well,I had an old switch,replaced the one on the mower==Same problem,so I don't think that both switchs would have the same problem....but thanks,anything else?????
     
  4. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    Check all your wire harness ground wires and battery ground, Any rust or corrosion could be causing a intermittent ground.
     
  5. trull

    trull LawnSite Member
    from n.c.
    Posts: 8

    I know the audio alarm does not work,removed and checked it...is it possible that this keeps the temp and oil lights not to come on when you turn on the switch and if so would it also keep it from not cutting of with the switch..I have checked all grounds I could find...That wiring harness is a Bear to trace??? Thanks Guys
     

Share This Page