walker 26 hp efi 2002 mtsd problem running good

Discussion in 'Turf Renovation' started by jackhammer_34207, Mar 25, 2008.

  1. jackhammer_34207

    jackhammer_34207 LawnSite Member
    Posts: 6

    hi i have a walker 2002 with a 26 hp efi engine .it seems to be fouling my plug out one plug has lot of black build up the other seems moist.when its running it spits and sputters .i changed the plugs put new filter it it still no luck getting it running better .if anyone has had this problem please please let me no how to fix it cant afford to put in shop thank you and god bless
     
  2. jackhammer_34207

    jackhammer_34207 LawnSite Member
    Posts: 6

    i pull off the o2 sensor it was very very dirty with heave carbon build up .im cleaning with krud cutter and blowing it out with my air compressor .i will see if that works i read in another form this worked .the engine run to good for a blown head gasket
     
  3. Smith Lawn & Landscaping

    Smith Lawn & Landscaping LawnSite Senior Member
    Posts: 352

    check to see if your fuel line is clogged up if so clean it and maybe replace your fuel filter.
     
  4. David Grass

    David Grass LawnSite Senior Member
    Posts: 485

    see if oil is getting sucked into your AIR filter. This will make it sputter, as it is getting choked. I have to keep my oil level LOW on the scale to keep this from happening to me.
     
  5. 2stroke

    2stroke LawnSite Senior Member
    Posts: 261

    sounds like u are due for a commpresion test.
     

Share This Page