walker blues

Discussion in 'Mechanic and Repair' started by AffinityLawns, Oct 6, 2002.

  1. AffinityLawns

    AffinityLawns LawnSite Member
    Posts: 6

    My walker has 700 hrs. and has been very well maint. and taken care of! I have had no problems at all with her other than occasional starter sticking after cranking and sometimes not kicking over like it should. We cranked her up to load her on the truck fri. morning and all the sudden a loud noise and she went dead, and if you try to turn it over now it turns rather slow and makes a disturbing noise, my fear is an internal engine problem. I am pretty sure that the warranty is only for 2 yrs. and the unit is about 2.5 yrs. old. I would be very greatful for any imput and or advice as to what my problem may be and the best option as to resolving it!

    Thanks in advance,

    Lee
     
  2. vipermanz

    vipermanz LawnSite Bronze Member
    Posts: 1,773

    what model engine does it have, is it single cyl or twin?, you might have a broken connecting rod .:(
     
  3. AffinityLawns

    AffinityLawns LawnSite Member
    Posts: 6

    It's a 2 cyl. 20 hp. it's a 99 model and i was thinking conn. rod also, but dont you think it would of have been knocking or something before it went, all the way until this incident we have had no problems at all, no smoking, knocking etc...
     
  4. captdevo

    captdevo LawnSite Senior Member
    Posts: 932

    sounds like you may have sheared the flywheel key...

    or even possibly broke a bendix on the starter.

    does it backfire? does it change if you add a booster to the battery?

    if it's got oil, and wasn't knocking, i highly doubt it's anything major.

    Dave
     
  5. AffinityLawns

    AffinityLawns LawnSite Member
    Posts: 6

    It only backfires when you cut it off after running it, and it does not change much when you put a boost to it.
     
  6. captdevo

    captdevo LawnSite Senior Member
    Posts: 932

    it will run then?

    it is just real slow turning over with the starter?

    any noise while running?

    remove the belts to the engine, then try it.
     
  7. AffinityLawns

    AffinityLawns LawnSite Member
    Posts: 6

    It would not run, I was responding to when it was running. I carried it in today and the problem was a broken crank, the best they could tell it seems that the cam-shaft gear broke a few teeth thus snapping the crank they said it was the first time they have ever seen it happen and the bummer is that the unit is 2 yrs. and 3 months old. They stated that they have no idea what could of caused it, you could still see the stamps on the cylinder wall just as if it came off the show room floor, head was in top condition, so they encouraged me to call the kohler dealer and see if they would help me out. The mechanic said my best option was to trash the old and stick on a newby, what do you guys suggest I do ? What is a reasonable price for a new engine installed, or where can i get the best price on the engine? Thanks for any and all advice!!!!!!!!!

    Lee
     
  8. captdevo

    captdevo LawnSite Senior Member
    Posts: 932

    wow, odd.....

    i sell new kohler 20hp for walkers for $1369 delivered to your door...tax free


    let me know.

    (319)-372-MOWR

    Dave
     

Share This Page