Walker mower 26 hp efi stalling out

Discussion in 'Mechanic and Repair' started by trock, Jul 22, 2013.

  1. trock

    trock LawnSite Senior Member
    Posts: 430

    Hi it did it in very hot weather it was 97 last week i keep it in an enclosed trailer. Went to mow in the morning and it was fine. Then in the afternoon it started and wont stay running. Its cool now about 75 and still the same issue.....
     
  2. ZX12R

    ZX12R LawnSite Senior Member
    Posts: 785

    So,last week was the first time it acted up? What year is machine and how many hours?
     
  3. bligh61

    bligh61 LawnSite Member
    Posts: 239

    Check safety switches
     
  4. trock

    trock LawnSite Senior Member
    Posts: 430

    2005 with 1900 hrs
     
  5. ZX12R

    ZX12R LawnSite Senior Member
    Posts: 785

    Do you still have original fuel pump? I just had the original pump replaced about a month ago. Machine is a 2003 and had 2440 hours on it. It ran like crap at idle and full throttle struggling to run missing like crazy.May want to have that checked if machine is running that bad. Mine was operating in the 20's where 39 psi is where it should have been.

    Hope you get this sorted out quickly.
     
  6. trock

    trock LawnSite Senior Member
    Posts: 430

    Fuel pump was replaced in april this year.
     
  7. ZX12R

    ZX12R LawnSite Senior Member
    Posts: 785

    Oh,can you use your walker at all ? Do you notice that your engine runs rich?Sometimes,with or without the right wind,you can smell it,especially on hotter days when the motor does not need as much fuel . It can run rich without throwing a code.Grounding problems can cause this.

    In march of 2004,Kohler put out a service bulletin on proper grounding of 26 EFI motors.They have upgrade kits depending on the computer you have and the time of production.

    May be something to check out also.
     
  8. FryDaddy

    FryDaddy LawnSite Member
    Posts: 145

    I had a similar issue with my 27 Kohler (not efi) and it was a bad coil pack after replacing plugs, filters, cleaning carb. drove us crazy trying to find the problem.
     
  9. jetta

    jetta LawnSite Member
    Posts: 223

    the machine is 2 yr old and would die just after start up . repeated starts I could get it to run then die later, just shut off took many tries to get going again sometimes I could finish the work but eventually had to replace the relay.
     
  10. ZX12R

    ZX12R LawnSite Senior Member
    Posts: 785

    So,one coil was bad and did you change both? Can a coil be tested to see if its bad with a volt meter or another tool? Was the problem worse as temps rose or motor was hot?
     

Share This Page