walker mower 26efi 2002 problem

Discussion in 'Lawn Mowing' started by goodone2, Feb 8, 2012.

  1. goodone2

    goodone2 LawnSite Member
    Posts: 2

    My Walker mower 26efi 2002 has a problem, When the motor is running for around 20 mins in cutting time the motor slow down and will not cut the lawn, so i turn off the motor for around 2 mins restart and i get the same problem in 10 mins or less. just over 2600 hours, Can anyone help me?
    I have change the spark plugs, oil, fuel pump, fuel lines,
     
  2. dhardin53

    dhardin53 LawnSite Senior Member
    Posts: 711

    The early efi from Kohler had this problem, Dixie Chopper had a big falling out over it (and a few other issues) and dropped anything to do with efi and Kohler and now relies on Generac Motors.

    If i remember right some time you can replace a sensor or two, but most the time it is the control box. Very expensive I am told.
     
  3. goodone2

    goodone2 LawnSite Member
    Posts: 2

    Thanks I will put new sensors on and see how it goes, As i have just got myself a MC 20hp walker rideon as i will fix my 26hp later.
     
  4. Richard Martin

    Richard Martin LawnSite Fanatic
    Posts: 14,700

    Dixie is still using a variety of Kohler engines from 25 to 40 horsepower.
     
  5. Landrus2

    Landrus2 LawnSite Platinum Member
    Posts: 4,811

    Don't get any sensors yet take a compression text before you start the engine in the morning and one after 20 minutes of run time compere them and see if they in with factory specs. :waving:
     
  6. fizzy

    fizzy LawnSite Member
    Posts: 5

    I have the same year. Try taking off the plate in front of the rear tire, there is a sensor held on with two screws that reads of the fly wheel the fins get dirt and grass in them I just clean them off and it runs great. Or this part could be damanged from your rear tire hitting the plate. Part is cheap.
     

Share This Page