Walker Not Cutting Right

Discussion in 'Mechanic and Repair' started by the angler, Jun 15, 2008.

  1. the angler

    the angler LawnSite Member
    Posts: 56

    i have a walker with the 52 inch deck i just started to notice its not cutting clean it looks like its leaving to trails of grass thats kind of bent over and not cut ........ my blades are sharp i just did them today ...could this be caused by the belt slipping ????? im not sure how tight it should be i might need a new spring that puts pressure on the belt >>>> any thoughts?
     
  2. bigclawn

    bigclawn LawnSite Senior Member
    Posts: 413

    change to a new belt and it should be fine
     
  3. justgreen

    justgreen LawnSite Member
    Posts: 42

    did you find the reason for the cut leaving trails?

    Also, what engine combo are you using with this deck?
    I have a 36" and looking for a 52" GHS or a 62" Side
    Its the 26EFI engine.

    Just Green
     
  4. Looking Good Lawn Service

    Looking Good Lawn Service LawnSite Senior Member
    Posts: 272

    Do you have walker brand blades, the aftermarket ones dont cut as well, also are the blades worn out, if so they lose cut quality. But most importantly, was the rear screen in the hopper clean, if its clogged the machine doesnt suck up the grass well, thus not creating a good vacuum , make sure all blower housing and tubes are clean as well as bottom of deck and deck side vents. This worked well for me.
     
  5. KS_Grasscutter

    KS_Grasscutter LawnSite Gold Member
    Posts: 3,335

    Is it a GHS or SD deck?
     
  6. Itsgottobegreen

    Itsgottobegreen LawnSite Silver Member
    Posts: 2,177

    I had the same problem with my 62". Left 6" was not cutting or cutting 1" higher. Walker is buying mine back.
     

Share This Page