walker problems

Discussion in 'Turf Renovation' started by lawnrangeralaska, Aug 17, 2006.

  1. lawnrangeralaska

    lawnrangeralaska LawnSite Senior Member
    Posts: 436

    my machines service engine light is on and not sure waht to do. i guess i could change the oil, but it is only 30 hours away from needing it and the air filter was fine.
     
  2. above all

    above all LawnSite Member
    Posts: 60

    I've been told that if that light is on, you might have only 5-10 pounds of pressure in your crank case. The only time i've seem mine on was when i changed my oil and only put one qt back in, ran the machine for a few days before the light saved my azz. Good luck Do tell us what you find.
     
  3. lawnrangeralaska

    lawnrangeralaska LawnSite Senior Member
    Posts: 436

    i changed the oil today and installed a new filter, this machine still has the light on and i checked the air filter and it didnt seem that dirty. i even removed the instrument panel and disconnected the light and re connected while i was installing a new light switch for my walker lights.
     
  4. MOW ED

    MOW ED LawnSite Fanatic
    Posts: 5,028

    I'm assuming its the EFI that has the light on as there arent many others that have a set up like this. Take the O2 sensor out and check to see if its clean. I had it happen once and just blew compressed air into the sensor. It did the trick. Now I know that there is a way to get the codes out of the mower by using the key. There is also a link somewhere on this site to find what the codes mean and I will look around for it.
     
  5. MOW ED

    MOW ED LawnSite Fanatic
    Posts: 5,028

  6. above all

    above all LawnSite Member
    Posts: 60

    Wow, Mr. MOW ED you are gold. Infomation and directions from good people like you is Pricele$$. Thank you.
     

Share This Page