1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community on the Franchising Forum.

    Dismiss Notice

Walker PTO issue

Discussion in 'Mechanic and Repair' started by nickslawnltd, Mar 20, 2012.

  1. nickslawnltd

    nickslawnltd LawnSite Member
    Posts: 166

    I tore a part my first walker and put back together. This is a 93 with 20HP Kohler. Everything is back together and running fine other than when I pull the lever up to engage blades it does nothing I have to push down on the lever the it works:confused:I've searched the net too no luck so wondering if anyone here can steer me to what I'm missing
     
  2. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

    Here's a MT linkage pic, You didn't post a model.....

    Make sure you didn't reverse a rod or pivot arm, It sounds to me you don't have the engagement idler pulley running on the inside of the belt.....

    Walker MT PTO.JPG
     
  3. nickslawnltd

    nickslawnltd LawnSite Member
    Posts: 166

    It's a GHS. I can't seem to make any sense of the diagram where I'm out. I'll snap a pic or two and see if I can figure out how to post them :dizzy: I should have made a few more mental notes but figured I could go off my other units but there different yet again
     
  4. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

    GHS stands for "Grass Handling System" which is the style deck not the unit model that I know of, Look at the model tag on the unit frame....
     
  5. hvlawncare

    hvlawncare LawnSite Member
    from yessir
    Posts: 7

    I'm not familiar with the older models, so I could be wrong. However, if you're PTO shaft is not turning, its the shear pin located right between your legs where the pto connects to the deck pto
     
  6. nickslawnltd

    nickslawnltd LawnSite Member
    Posts: 166

    No its turning. It's just when I pull up on the lever it does not engage. I have to push down to engage it. It's working backwards:hammerhead:
     
  7. nickslawnltd

    nickslawnltd LawnSite Member
    Posts: 166

    Thanks for the replies guys but I got it figured out. Realized I didn't have the belt over the tension pulley:hammerhead: too much fixing and other things going on at once and I missed something simple and got frustrated its nice to take a step back once in a while and then go back to it
     
  8. KrayzKajun

    KrayzKajun LawnSite Fanatic
    Posts: 10,742

    Glad you got it figured out.
    Posted via Mobile Device
     
  9. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024


    Hmmm...... :weightlifter:
     
  10. nickslawnltd

    nickslawnltd LawnSite Member
    Posts: 166

    So that's what you meant restrorob. Well thank you :drinkup:
     

Share This Page