wb will not start

Discussion in 'Mechanic and Repair' started by K.Carothers, Aug 18, 2006.

  1. K.Carothers

    K.Carothers LawnSite Bronze Member
    Posts: 1,124

    My wb is giving some troubles.

    It's a 17hp kawi electric start.

    It seems at times that it's not getting a spark. I changed the spark plug and tested to see a spark -

    I see no spark - I sprayed starter fluid in the carb with no success.

    It seems it has its own mind when it wants to throw a spark.

    What could the problem be?


    Thanks,

    kc
     
  2. MowerMedic77

    MowerMedic77 LawnSite Bronze Member
    Posts: 1,164

    Model# and Spec# will help with diagnosis , but you may have coil failure or an external issue with the safety's causing your issue.
     
  3. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,022

    Ditto what MM said, With the engine numbers we can see exactly which ignition system ect. you have and give a better idea what to check for.
     
  4. ChadsLawn

    ChadsLawn LawnSite Bronze Member
    Posts: 1,110

    What about the safety switches. Did you check them?
     
  5. K.Carothers

    K.Carothers LawnSite Bronze Member
    Posts: 1,124

    Sorry about the delay. It started and I put it off only for it to start again.

    Model FC54GV

    The motor just stops when running or it never starts and I burn through a battery trying to start it.


    Thanks,


    ken
     
  6. K.Carothers

    K.Carothers LawnSite Bronze Member
    Posts: 1,124

    Help!


    kc
     
  7. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,022

    Sorry I missed ya KC, Below is a wire diagram. It may look a little different than yours but the wire on the igniter is the same on all. Disconnect this wire to the ignition switch and re-check for spark, If you now have spark the problem is with the unit harness or a safety switch or maybe even the ignition switch.

    If you still have no spark go to my next post for the coil and igniter test.

    Good Luck

    FC 540 Wire Harness.jpg
     
  8. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,022

    And the component test....

    FC 540 Ignition Test.jpg
     

Share This Page