1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Western control box

Discussion in '<a href=http://www.plowsite.com target=_blank ?>Sn' started by 2 shot, Feb 9, 2001.

  1. 2 shot

    2 shot LawnSite Member
    Posts: 6

    Has anyone had this problem:
    Toward the end of the night while raising my plow it
    got stuck in the raise position and the stick returned
    to the neutral position. The only way to get the plow to
    move after that was to jam it into raise a couple of
    times. I checked all of the connections in the cab and
    at the front of the truck. I think the problem is in
    the box because when it got "stuck" it would go all the
    way up and the pump would start to whine.
  2. plowjockey

    plowjockey LawnSite Senior Member
    Posts: 332

    If this is a setup with cable control. I would say to check inside the pump unit where the cables go in for ice.
    I keep mine packed with a light grease to keep water out and also put silicone around the cable fittings where they go into the pump housing.

    Happy Plowing
  3. sly

    sly LawnSite Member
    Posts: 15

    plowjockey are you happy with your cable unit?

  4. plowjockey

    plowjockey LawnSite Senior Member
    Posts: 332

    My unit is of undetermined age and I started out with putting on new hydraulic lines and also new cables. The unit as a whole is doing a fine job. I would like to update someday to one with the solenoid controls, but for the present the cable controls do a fine job. I am constantly refurbishing the whole package simply because I have no idea what kind of life it has had. It has performed well all winter (knock on wood) and I am just fine with it.

    Happy Plowing

Share This Page