What is wrong with my kohler in the dixie

Discussion in 'Lawn Mowing' started by bdemir, Apr 13, 2000.

  1. bdemir

    bdemir LawnSite Senior Member
    Posts: 610

    Today towards the end of the day my dixie chopper w/20hp or 22hp kohler was backfiring like one after the other . If this a sign of engine trouble what can i do to prevent it or check it out. It sounds like the mufler is exploding over and over.Also my lucknuts came of today too. Wow got to watch out for those. Didnt even notice till my wheel was wobbling. But today was my first day on the chopper for a long time. God bless.
     
  2. Hello:<p>What were you doing when it backfired?<p>Cutting, shutting down, ideling or what?<p>Did it only do it cold or did it do it hot only or did it do it all the time?<p><p>----------<br>GrassMaster - Home: www.lawnservicing.com<br>My Start Up Page www.lawnservicing.com/startup/
     
  3. bdemir

    bdemir LawnSite Senior Member
    Posts: 610

    Mr. Grassmaster, <br>It does it when i try to at fu;ll speed and when cutting. (i have 6 blades on it and i dont think its handling it too well) It only does it when i try full throttle and it seems to backfire when i hit bumps but its hard to tell it just keeps doing it when i go at full speed.
     
  4. DMC300

    DMC300 LawnSite Senior Member
    Posts: 325

    SOUNDS LIKE THE KILL SWITCH UNDER YOUR SEAT.SEE IF IT IS STILL HOOKED UP,IF IT IS BY-PASS IT.SEE IF IT STILL DOES IT.<p>----------<br>DON<br>LIANNES' MOWING
     
  5. bdemir

    bdemir LawnSite Senior Member
    Posts: 610

    Thanks DMC i am going to try that now.
     
  6. Eric ELM

    Eric ELM Husband, Father, Friend, Angel
    Posts: 4,831

    Also check the connecters on the ignition switch. I have seen the connectors get corroded and a bump might make them loose connection. Just another thing to try. <p>----------<br>&lt;a href=&quot;http://www.townserver.com/elm/&quot;&gt;Eric@ELM&lt;/a&gt;<br>
     
  7. bdemir

    bdemir LawnSite Senior Member
    Posts: 610

    Thanks Eric I will try that too.
     
  8. Hello:<p>It sounds like a electrical connection problem of sound kind.<p>When it starts doing it again, see if it will do it setting still. I would check seat safety switch first, once the seat is eliminated, then check all safety switches, then electrical connectors on complete unit.<p>Please let us know what you find is the problem.<p>----------<br>GrassMaster - Home: www.lawnservicing.com<br>My Start Up Page www.lawnservicing.com/startup/<br>
     
  9. thelawnguy

    thelawnguy LawnSite Silver Member
    Posts: 2,412

    My 18 in my exmark did that for a month, then one day decided it wasnt going to start at all. Ended up being crap in the gas, got thru a bad fuel filter and plugged the main jet. A 1/2 hour labor at the shop cleaning out the float bowl and a new filter and it was good to go. Hasnt done it since.<p>Bill
     
  10. ADMServices

    ADMServices LawnSite Member
    Posts: 68

    After ruling out the electrical problems move to the fuel filter and carb like the lawn guy said. We have 4 choppers, and 3 bunton walk behinds all with Kohler engins. make sure you change your fuel filter reg basis, clean your carb with some carb cleaner, and you may need to adjust the carb a bit. This usually happens to ours if they are running a bit too rich. <br>Good luck-----&gt;let us know if this fixes the problem<p>www.admservices.com
     

Share This Page