What is wrong with this picture, part 2

Discussion in 'Mechanic and Repair' started by BigFish, Jul 12, 2012.

  1. BigFish

    BigFish LawnSite Gold Member
    Posts: 3,262

    Not counting the agent orange all over the unit! 003.JPG

  2. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    Plug wire is pinched under the blower housing and possible fuel line leakage among many other things.....

    We get a new camera along with the new meds Fish ? :)
  3. C Jovingo Landscaping

    C Jovingo Landscaping LawnSite Senior Member
    Posts: 436

    Is that fuel line laying on metal (metal that can get HOT) & spark plug wire?
    Posted via Mobile Device
  4. dutch1

    dutch1 LawnSite Silver Member
    from Jayhawk
    Posts: 2,231

    Among the other things Rob eluded to, it appears that there may be a crack in the fuel line barb, just above the fuel line attachment.

    There also appears to be a crack in fuel pump mounting bracket just above the vacuum hose although that would not likely affect running.

    On the other hand, it's possible that these "old eyes" may be tricking me so late in the evening--they should be shut by now.
  5. lawdawg

    lawdawg LawnSite Member
    Posts: 22

    Plug wire has a hole rubbed in it.
  6. piston slapper

    piston slapper LawnSite Platinum Member
    Posts: 4,245

    The tygon would probably have been ok if it had a clamp on it...

    I'm due to get one of these right ...sooner or later...
  7. The Lawn Ranger CT.

    The Lawn Ranger CT. LawnSite Member
    Posts: 194

    What is that agent orange stuff on the mower~?
    I've noticed that from time to time on mine after cutting some lawns~
  8. BKTP

    BKTP LawnSite Member
    Posts: 32

    the fuel line appears to have fuel in it between the barb and the pump. Hence the OBVIOUS leak evidenced on the cowl. Could be a simple as a clamp on the fuel line, to possibly a broken fuel connector on the pump but I can't see that for sure but like the previous poster I do see sumtin there.

    Not sure I would have caught the spark plug wire worn spot unless I was aware of an electrical issue. The leak issue is oblivious :)
  9. BigFish

    BigFish LawnSite Gold Member
    Posts: 3,262

    Rrob, plug wire's not pinched, has a ton of space 'tween the plastic shroud and the shield. Fuel's not leakin'. The camera's 4 years old. The meds, however.......ahhh, the meds................!

    CJL, fuel line's not laying on the metal or touching the plug wire.

    Dutch, no cracks.

    Ldawg, no hole in the plug wire.

    Slapper, Bingo!

    LR CT , I think it must be some sorta....... , I don't know!

    BKTP, the obvious leak on the cowl is actually runoff from when I oiled the
    choke control cable on the dash panel above it. it's mounted vertical so as to catch the rain etc and rust.

    What I consider wrong with the picture is the Tygon tubing! That crap gets hard in no time and will almost fall off by itself! The only thing holding it on is the barb at the pump and the filter.
    A clamp would help! Since I'm forced to use that chit I at least put a ty-rap on it to act like a clamp.
  10. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    :clapping: .:clapping: .:clapping: . :drinkup:

Share This Page