Whisteling noise, Toro Z150 2003 Help!

Discussion in 'Mechanic and Repair' started by rdran5, May 1, 2005.

  1. Just noticed a loud metallic whistle, It seems to start after the machine is warmed up, and rolling, can't pin point it, it isn't coming from the wheels, I don't think. It is there with the pto engaged or not engaged. Very noticable at low RPM when rolling down a drive way.
    Any input or advice is appreciated.
    And yes, everything has been greased properly and the belts are less than 15 hours.
     
  2. grass_cuttin_fool

    grass_cuttin_fool LawnSite Gold Member
    Posts: 3,503

    Im not famliar with that model but could the hand brakes be adjusted a lil to tight and squealing, my toro walkbehind does this but im not sure how the brakes are on the Z
     
  3. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

    I'm not Familiar with this unit either, But I've seen similar symptoms and found a bearing going bad in the electric P.T.O. clutch once warmed up and a idler pulley a couple times. For what its worth




    14yr. Briggs & Stratton Master Service Technician
    Kohler Factory Trained
    Tecumseh
    Honda
    Kawasaki
    Onan
    Robin
    Factory Trained Polaris ATV & Watercraft
     
  4. Thanks for the suggestions, I played around with the hand brake to day and it seemed to have a connection to the squealing, 2 year warranty expired in April, I should not have put it off.
    We live We learn..
    If yall think of anything else let me know.
    R
     

Share This Page