why are my 2 brand new EXMARKS JUNK

Discussion in 'Lawn Mowing' started by ronnie Greenwood, Apr 28, 2003.

  1. ronnie Greenwood

    ronnie Greenwood LawnSite Member
    from Il
    Posts: 33

    bet that got alot of peoples attention here is the proablem I bought two brand new exmarks in the beging of the seasonweek later proablems in both of them lets start with the fact that I was mowing one of my properties and a nut fell off on one of them and the handle rod fell off so it started sping in circles I let go of it so that it would stop no this thing went heywirebecouse the one handle got stuck and I was chasing it around to shut it off take it in go get that fixed 2 days later the same mower just stops will not go will not turn take it back there and it works so they figure no big deal now the gear shifter sticks and is hard to swich gears. oh yea when in netural it still goes this thing is such a pice of **** there are so many little things going wrong with it I think instead of spending $3000 on this piece I would have been beter of buying a one hundred dollar yard machine. another thing the exmark dealer who sold it to me drilled holes into it to allighn it I thinking that can not be right becouse you shouldent have to drill differnt holes to allighn it now they got it so tight it practically jumps when your turn what do I do sorry no about the lack of english skills I just pissed off and dont care to correct them now:blob2: :blob2: :blob2: :blob2: :blob2: :blob2: :blob2:
     
  2. scottishmaximus

    scottishmaximus LawnSite Senior Member
    from ohio
    Posts: 286

    sounds like whoever set the mower up doesn't have a clue. any other dealers? what model?
     
  3. ronnie Greenwood

    ronnie Greenwood LawnSite Member
    from Il
    Posts: 33

    it is a 48" floating belt drive
     
  4. CBB

    CBB LawnSite Member
    from MS/LA
    Posts: 147

    I would post this at the Exmark forum. They will have someone on this problem immediately.

    As far as the problems you described, it sounds like your dealer did a poor job of setting the mower up for you. Each of these that you are talking about would be prevented by proper set up and servicing.

    Like I said talk to the folks at Exmark, they will make it right quickly.
     
  5. LawnMower

    LawnMower LawnSite Senior Member
    Posts: 653

    That paragraph has the longest running sentences Iv ever seen.
    ;)
     
  6. CBB

    CBB LawnSite Member
    from MS/LA
    Posts: 147

    By the way when you let go of the machine, it should have killed the engine immediately. What happened there?
     
  7. ronnie Greenwood

    ronnie Greenwood LawnSite Member
    from Il
    Posts: 33

    the one handle was stuck down so it just kept going till it got dizzy
     
  8. jsr2741

    jsr2741 LawnSite Senior Member
    Posts: 392

    I was only able to read about 1/4 of that post and then my eyes started crossing.

    Dealer did a crappy job on your set up. Post it on the Exmark site and have them rectify the problem.

    Good luck.
     
  9. AltaLawnCare

    AltaLawnCare LawnSite Senior Member
    Posts: 962

    I'm demoing a 48" ECS Metro HP now....

    Very smooth. Its takes a little while to get used to a walk behind, anyway, and that thing sounds like its way out of adjustment.
     
  10. ronnie Greenwood

    ronnie Greenwood LawnSite Member
    from Il
    Posts: 33

    I am not puting down exmark at all. I just think that someone did not know what they were doing. But the fact of it moving fast in neutral and the troubled gearshift worrys me.
     

Share This Page