Wiring Toro wb w/ Kohler engine.

Discussion in 'Mechanic and Repair' started by mexiking, Mar 8, 2008.

  1. mexiking

    mexiking LawnSite Senior Member
    from NJ
    Posts: 564

    Hey everybody, I'm replacing an engine on a 42" Toro Hydro which had a 15hp Kohler Command. I am putting a Kohler Courage 17hp. The engine is mounted I'm just having trouble with the Red cable from the engine which is to power the Fuel Solenoid. Where do I connect that red cable coming from the engine to? Do I just have to give it power or what? Any help would be appreciated, thanks.
     
  2. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    It needs to be connected to a switched battery source (ignition switch) so it doesn't operate when the engine isn't running.
     
  3. mexiking

    mexiking LawnSite Senior Member
    from NJ
    Posts: 564

    that's it? I think I had tried that but it still didn't turn on... Do you guys know if Kohler Courage 17hp Vertical is supposed to work with out the fuel pump? I installed a 20 hp Courage and it did h ave a fuel pump. Would it still be able to run w/ out a fuel pump ?
     
  4. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    You must have power in the start position as well, If you had it wired properly it should have worked.

    Yes a engine with a fuel pump will run without as long as the fuel tank is mounted high enough for the fuel to gravity feed to the carb.
     
  5. mexiking

    mexiking LawnSite Senior Member
    from NJ
    Posts: 564

    The engine starts to crank up, but it still won't start... I have the fuel line coming in from a high angle it should start up, not sure what else is missing. It looks like I have the wiring done correctly. I'll try to post pictures.
     
  6. caseymax

    caseymax LawnSite Member
    Posts: 16

    Hi You can hear the solenoid click when you hook 12v to it. You might have your hot wire hook to side of the ignition switch that turns off when you go to the start position. Koler uses a jumper ground wire from engine block to the carb. I would run a wire from battery to red wire and see if it clicks when you touch the red wire. Dose it have spark to the plugs. It would help if you give the spec number. There are a lot of reasons that it is not starting? Give the Id numbers and we can get you going.


    Thanks MAX.......
    Monrovia In
     
  7. mexiking

    mexiking LawnSite Senior Member
    from NJ
    Posts: 564

    The solenoid Does click when the red wire touches + I will get the specific model # of engine.
     
  8. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    Well, I was waiting for pics you were going to post.....

    Is the 17hp a brand new engine or a used taken off another unit ?
     
  9. mexiking

    mexiking LawnSite Senior Member
    from NJ
    Posts: 564

    I got it working Restrorob, The grounding isnt "grounded" Properly, I wiggled them around while trying to start it and that was the problem. I didn't have time to do it right now since it got very cold working in my garage. Will do tomorrow. Thanks for help
     
  10. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    Good Deal.....[​IMG]
     

Share This Page