wrong about doubles?

Discussion in 'Lawn Mowing' started by locutus, Oct 31, 2003.

  1. locutus

    locutus LawnSite Bronze Member
    from NC
    Posts: 1,266

    Last week I replied to a thread concerning doubles and stated that I did not like them due to the fact that in heavy grass they made my blade belt slip. I took them off and put on gators for my leaf cleanups. I noticed that after removing the doubles there was a slight bit of slippage when engaging the blades, other than that everything seemed o.k., Except for that smell. I thought It may be some leaf debris near the muffler or perhaps a little oil burning. Remember now, Ive been using these gators for a week and smelling that smell. I looked under the mower today and found the source of the smell. Somehow while changing blades the belt came off of the engine pulley and went up on the clutch area. Damndest thing Ive ever seen. This is why I was having slippage with the doubles. I still cant understand how it ran so long with the belt off of the engine pulley. I think I'll give the doubles one more try. p.s. mower is Exmark metro hp.
     
  2. dvmcmrhp52

    dvmcmrhp52 LawnSite Platinum Member
    from Pa.
    Posts: 4,205

    Good luck with them.Let us know how they work.
    Our experience with doubles is varied....Depends on the circumstances how well they work.
     
  3. PaulJ

    PaulJ LawnSite Bronze Member
    Posts: 1,776

    try some belt drssing spray on the belts. I've found it helps when the belts get some age to them.
     
  4. bobbygedd

    bobbygedd LawnSite Fanatic
    from NJ
    Posts: 10,178

    i put doubles back on yesterday for the fall season. LOVE IT, LOVE IT, LOVE IT. one yard in particular, covered with leaves, ran over it twice (no catcher), and it looked great, couldnt see a crumb. i have gators on top of mulchers
     

Share This Page