• Online Events For Landscapers!
    With GIE+EXPO cancelled, virtual education and product launches are filling up the fall. Check out dates for Caterpillar, Exmark, NALP, and more. Click here to learn more.

1985 Suburban 4wd question

djm

LawnSite Member
Location
nj
Hi, I just bought an 85 Surbuban 2500 Sierra Classic for $1000. Besides <br>a godawful amount of rust it's in great shape. The 4WD system does <br>not work, I think it's the hubs. I'm pretty sure the transfer case <br>is OK, in 4WD the front driveshaft does turn. I turned the hubs but <br>they don't lock, any ideas on what could be wrong? Any advice is greatly <br>appreciated, this is my first 4WD truck and I'm anxious to get it <br>working. Please send comments/advice to the board as well as my e-mail <br>address djmdammit@yahoo.com because I don't get on the internet that often. <br>Thanks <br>Dan
 

yortengel

LawnSite Member
Location
Clawson, Mi
We need to know what type of hubs you have, Auto matic or manual? The auto matic hubs require the front drive shaft to turn to engage them. the manual hubs just have on and off. Either way, you will need to go to the library and get a service manual. They are either assembled incorrectly (common problem) or they are blown. Remember, only one hub has to not work for your 4WD to be inoperative. Also check the front drive shaft, the slip yoke has a tendency to strip out if not greased regularly (another common problem) Good luck.<br>Troy<br>PS Don’t forget to also grease the CV joint in the front drive shaft, It has a small grease fitting in between the two U-Joints. You will need a needle fitting for your grease gun. Good Luck.<br>
 
Top