2015 Toro 30 Timemaster won't start

Discussion in 'Mechanic and Repair' started by Jason Price, Sep 19, 2017.

  1. Jason Price

    Jason Price LawnSite Member
    Messages: 5

    I have a timemaster that will not start. Was mowing a lawn all of a sudden it stopped running hasn't started since. I have changed spark plug, magento and carburetor. When I pull the cord everything turns but no fire.
     
  2. oqueoque

    oqueoque LawnSite Gold Member
    Male, from Jersey
    Messages: 3,275

    Have you tried starting it with the air filter off?
     
    hort101 likes this.
  3. Jason Price

    Jason Price LawnSite Member
    Messages: 5

    Yes tried it this evening with it off, also check spark - it was good. I also replaced kill switch.
     
  4. MWHC

    MWHC LawnSite Member
    from Wyoming
    Messages: 217

    Make sure the flywheel key has not sheered. May be sparking at the wrong time.
     
  5. BigFish

    BigFish LawnSite Platinum Member
    Messages: 4,120

    Service manual fer motor can be had here:
     
  6. JLSLLC

    JLSLLC LawnSite Fanatic
    Messages: 7,342

    How about the inline fuel filter
     
  7. ztman

    ztman LawnSite Bronze Member
    Messages: 1,094

    How about fuel?
     
  8. Jason Price

    Jason Price LawnSite Member
    Messages: 5

    I checked flywheel key still good, magnet on flywheel still good. Fuel Filter and Carb are new.
     
  9. sjessen

    sjessen LawnSite Platinum Member
    Male, from Knoxville, Tn
    Messages: 4,381

    Those 190cc engines are crummy.
     
    JLSLLC likes this.
  10. ricky86

    ricky86 LawnSite Silver Member
    Messages: 2,091

    Take the valve cover off. See if a push rod popped out of place. Overhead valve engines need adjustment from time to time.
     

Share This Page