1. Missed the live Ask the Expert event?
    Catch up on the conversation about fertilization strategies for success with the experts at Koch Turf & Ornamental in the Fertilizer Application forum.

    Dismiss Notice

2017 SCAG VRide Stalling

Discussion in 'Mechanic and Repair' started by S&H Mowing, Oct 12, 2017.

  1. S&H Mowing

    S&H Mowing LawnSite Member
    Messages: 30

    Scag 52" V Ride, 2017 model with the Kohler EFI. Yesterday when I was mowing, the mower chugged hard, when mowing thin grass. I had no issues getting it to the trailer. Belts tight, oil is filled appropriately, etc. I then started the mower while on concrete, full idle, no problem. Engage PTO, mower kills it's self as it doesn't have enough power. Any ideas on what it is?
     
  2. weeze

    weeze LawnSite Fanatic
    Messages: 12,616

    maybe a coil went out and it's running on 1 cylinder. that has happened twice on my kohler engine.
     
  3. ed2hess

    ed2hess LawnSite Fanatic
    Messages: 14,465

    No diagnostics on EFI engines?
     
  4. weeze

    weeze LawnSite Fanatic
    Messages: 12,616

    should be a check engine light on while it's running if it's one of the coils.
     
    ed2hess likes this.
  5. lawns4life

    lawns4life LawnSite Member
    Messages: 60

    I had a similar problem, surging & almost dying when engaging the blades on a 17' v ride with the efi. This was when it was less than 10 hours so may not be the same issue, but the dealer had to reset/reflash the computer to fix it. There was no engine light on
     
  6. SteveMeecanic

    SteveMeecanic LawnSite Member
    Messages: 2

    Check the ground wire on the engine mounting bolt. Right rear bolt i betcha its loose.
     

Share This Page