1. Missed the live Ask the Expert event?
    Catch up on the conversation about fertilization strategies for success with the experts at Koch Turf & Ornamental in the Fertilizer Application forum.

    Dismiss Notice

bad Coil ?

Discussion in 'Mechanic and Repair' started by Breezmeister, Jan 9, 2008.

  1. Breezmeister

    Breezmeister LawnSite Bronze Member
    Male, from South Jersey
    Messages: 1,784

    Last week I get a Toro snowthower come in with a no start problem. After going through it only thing I find wrong is, no spark. Put the coil on yesterday, button it all back up and nothing...no spark. Double and triple check everything and still no spark. Checked the magnets on the flywheel, very strong. Disconnect all the wiring , even the wire coming off the coil. Nothing.....So now I'm wondering if the new coil is defective ? Is there a way to test the coil and what I need to do it with ?

    B&S 190402 272001 830520
    Coil 398811 024847 828061

    Just wondering if this engine had points and it was switched over at some point ?

    Thanks :rolleyes:
    ericg likes this.
  2. Restrorob

    Restrorob LawnSite Fanatic
    Messages: 11,029

    That part number coil is the proper one for that engine, It will work even if the engine had points before or not.

    If you mounted the coil with the plug wire facing away from the block and set air gap (coil to flywheel distance) at 0.10-0.14" and with no kill wire hooked up it should be sparking.

    If you are checking spark with a neon type spark tester put the plug in the boot and hold it to a head bolt, If still no spark I would consider that new coil defective.
  3. Breezmeister

    Breezmeister LawnSite Bronze Member
    Male, from South Jersey
    Messages: 1,784

    That was what I was thinking, just wanted to make sure I wasn't having a brain fart ;) This is a first for me, a bad coil. And it's been a long time too that I even brothered to go back and read the little instruction sheet. You will get a :laugh: out of this, but I even dug deep into my tool box and got out my very old round spark tester that I got from Briggs
    Thanks Restro
    ericg likes this.
  4. Restrorob

    Restrorob LawnSite Fanatic
    Messages: 11,029

    Yeah, Those dang things sneak up on me from time to time.....:cry:
  5. dennes1

    dennes1 LawnSite Member
    Messages: 8

    Does the snowblower have another module connected to the coil and kill switch. My module went bad and I had no spark at the wire even. I replaced the module with a Mega Fire II brand $20.00 vs $110 for the toro brand. good luck
  6. themowerman

    themowerman LawnSite Senior Member
    from NJ
    Messages: 298

    Dumb question.....did you check the flywheel key???
  7. Landrus2

    Landrus2 LawnSite Fanatic
    Messages: 5,021

    Look for an open circuit check you sensors :weightlifter:

  8. Fisher40037

    Fisher40037 LawnSite Member
    Messages: 36

    What kind of starter does it have? 12v ? Or is it an AC starter?
    You must make sure that no voltage is getting to the coil through the
    kill wire, or you will destroy the new coil. So bad wiring, or bad key
    switch could be the real problem.
    If it was a sheared flywheel key it would still show spark at the tester.
    Being an 83 model, it likely had points originally, you have cut the wire
    going under the flywheel to the points?

  9. Breezmeister

    Breezmeister LawnSite Bronze Member
    Male, from South Jersey
    Messages: 1,784

    Not a dumb question, but yea, did check the key....
    ericg likes this.
  10. Restrorob

    Restrorob LawnSite Fanatic
    Messages: 11,029

    Guy's, Just for reference....

    Below is the coil in question, There is nothing to this system. The magnet passes the coil and energizes. The inner trigger coil tells it when to spark in relation to the magnet. With the above mentioned wire disconnected the only thing left to cause no spark is a weak magnet bad/defective coil or excessive coil to flywheel air gap. But I'm not sure backing a coil adjustment all the way off the flywheel (as far as the slots will allow) will cause no spark but only weak spark, I never tried doing this just to see.


Share This Page