Biggest gripe with Toro spreader sprayer.

Marine03112

LawnSite Silver Member
Just bought a new 2019 toro spreader sprayer. I have two gripes about the new machine. The biggest problem is the way they keep the impeller hooked onto the shaft. The clip they use falls off all the time. If you don’t have a bunch of them you have to have a nail or something. My son said hey this pin might work. A hitch pin cotter pin. Well worked great got back to work after 10 minutes of looking for something to get the impeller secured to the shaft. It’s total pain that’s now fixed for good. Next the new Kohler engine doesn’t have the same hill climbing capabilities as the Subaru. Don’t get me wrong love the way the new machine works great. Seems the bolts on tie rods now don’t move or need to be tightened yet. That use to be a pain till I lock tightened them. So with that said what are your experiences with your exmark or toro. What do you like and don’t like. I am curious with other people’s experiences.
 

That Guy Gary

LawnSite Gold Member
Location
SW Idaho
I have one on loan that I've put 100 hours in now. I've been running it hard, not gonna lie.

It seems to be prone to vapor lock. Been having it die on me in the afternoon when it's pushing 100, but it recovers quick.

I haven't had issues with the impeller falling off, now I have to look on Monday to satisfy my curiosity.

The Kohler seems to be using more gas too.
 
OP
Marine03112

Marine03112

LawnSite Silver Member
I have one on loan that I've put 100 hours in now. I've been running it hard, not gonna lie.

It seems to be prone to vapor lock. Been having it die on me in the afternoon when it's pushing 100, but it recovers quick.

I haven't had issues with the impeller falling off, now I have to look on Monday to satisfy my curiosity.

The Kohler seems to be using more gas too.
Might be specific to the toro model. The impeller clip I mean. Nothing but a pain in the butt.
 
OP
Marine03112

Marine03112

LawnSite Silver Member
Anyone else want to add here? What problems in the past have you had with your exmark/toro spreader sprayer? Gary I know had pressure issue. Mine was the bloody clip to hold the impeller on.
 

lawndude28

LawnSite Senior Member
Having an issue with the side deflector coming down too easy. Every time I git a bump. Spring looks fine and I don't see any missing parts, anyone had this issue before?
 

grass4gas

LawnSite Bronze Member
Bought mine this past January and right now have about 170 hours on it. The only problem that I have had with it was the throttle cable needed to be replaced. No other issues so far.
 
OP
Marine03112

Marine03112

LawnSite Silver Member
Bought mine this past January and right now have about 170 hours on it. The only problem that I have had with it was the throttle cable needed to be replaced. No other issues so far.
I have 568 hours on my other toro. Replaced the throttle cable. Then the impeller motor went. When I looked at schematic they forgot to put the lock washers on the mount for the motor. This caused a slight movement in it. That caused wear on the shaft and I am sure messed with the gears in the motor. That motor isn’t cheap. I will need tires for the machine next year all and all it is light years ahead of an permagreen and many others
 

jmlawns

LawnSite Member
I have 568 hours on my other toro. Replaced the throttle cable. Then the impeller motor went. When I looked at schematic they forgot to put the lock washers on the mount for the motor. This caused a slight movement in it. That caused wear on the shaft and I am sure messed with the gears in the motor. That motor isn’t cheap. I will need tires for the machine next year all and all it is light years ahead of an permagreen and many others
I now this is an old post but I am thinking of buying one of these. How are they on hills and turning radius? I currently run PG, my lawns run from 9000 sq ft to 60000 sq ft and average about 30000 sq ft.
 

Top