1. Missed the live Ask the Expert event?
    Catch up on the conversation about fertilization strategies for success with the experts at Koch Turf & Ornamental in the Fertilizer Application forum.

    Dismiss Notice

Bragging rights

Discussion in 'Irrigation' started by Mike Leary, Aug 9, 2011.

  1. SoCalLandscapeMgmt

    SoCalLandscapeMgmt LawnSite Silver Member
    Messages: 2,144

    I got nothing..... nothing exciting. We're installing 18 ESP-SMT and 7 Hermit Crabs for a client next week. That's about the most excitement we've seen all summer
     
  2. FIMCO-MEISTER

    FIMCO-MEISTER Banned
    Messages: 18,668

    I think the moral to Walkgood's story is that I need to offer pigtails in two colors.
     
  3. irritation

    irritation LawnSite Gold Member
    Messages: 3,591

    Replaced 523 PGP's (96.5% were leaky seals) with 5004's.
     
  4. FIMCO-MEISTER

    FIMCO-MEISTER Banned
    Messages: 18,668

  5. txirrigation

    txirrigation LawnSite Senior Member
    from Texas
    Messages: 977

    Dang, one site or over the year?

    I posted on a different thread pics of a 5004 running with PGP's and you can clearly see the advantage. Not as much mist, and much lower angle of throw.
     
  6. irritation

    irritation LawnSite Gold Member
    Messages: 3,591

    No, but here's a good example.
    [​IMG]
     
  7. FIMCO-MEISTER

    FIMCO-MEISTER Banned
    Messages: 18,668

  8. irritation

    irritation LawnSite Gold Member
    Messages: 3,591

    I don't wear boats and that's not my pic.
     
  9. FIMCO-MEISTER

    FIMCO-MEISTER Banned
    Messages: 18,668

    PLAGIARISM!




    Yeah I'm with you on the PGPs something went really south on them.
     
  10. WalkGood

    WalkGood LawnSite Bronze Member
    Messages: 1,910

    Doesn't look like the wiper seal is leaking. Just the screw-on collar is leaking. Perhaps it wasn't tightened correctly?

    I have also found that some very MUCH older PGP canisters do not mate up correctly with new guts-n-collars. Have to replace the whole unit or the screw top leaks. Anyone else have that happen?
     

Share This Page