CLIP XE ISSUES

TX Easymoney

LawnSite Platinum Member
Anyone using clip2go having issues with logging work? After hitting the start or stop button, it takes almost 10-15 seconds for the server to acknowledge our choice...its excruciating--
also noticing jobs being recorded as incomplete or not at all---operator error? possibly, though these crews have many years experience using the program.

The ridiculous lag also occurs when I log into clip2go on my computer-- no we are not located in an area with slow internet--- the problems began well over a year ago-
 
OP
T

TX Easymoney

LawnSite Platinum Member
They claimed that there were too many factors involved to place blame squarely on their servers-- looking at other software this winter -I'm tired of the rudimentary updates--
 

Mark Oomkes

LawnSite Fanatic
Location
Grand Rapids, MI
They're trying to push you to ITC.
 

That Guy Gary

LawnSite Gold Member
Location
SW Idaho
To clarify we use CLIPITC. Still slower than dirt.

The app is usually more responsive with GPS on, I think the lag is just waiting for a response. Anything on the website is horrible though.
 

Mark Oomkes

LawnSite Fanatic
Location
Grand Rapids, MI
To clarify we use CLIPITC. Still slower than dirt.

The app is usually more responsive with GPS on, I think the lag is just waiting for a response. Anything on the website is horrible though.
Interesting...
 
OP
T

TX Easymoney

LawnSite Platinum Member
They're trying to push you to ITC.
its not working---I listened to their sales guys a few years ago and switched ---there were so many issues with workflow etc/errors and unexplained occurrences that we switched back- this caused a whole host of other problems with QB and billing addresses/emails. 2 years ago, ITC was not ready for prime time...I couldn't manage to spit out a route sheet with all the work I needed to have performed.
 

Top