Lawn Care Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
10,525 Posts
Discussion Starter · #1 ·
Ok, just got my Exmark back about 2 weeks ago from a lower block rebuild. Now the hydro belt snapped and tore the wires out of the pto clutch. can't put them back in, you have to get a new one. Was a crappy design idea putting something that "fragile" next to a belt that cn break and tear it up. whats next, the starter? *trucewhiteflag*
 

·
Registered
Joined
·
10,525 Posts
Discussion Starter · #4 ·

·
Registered
Joined
·
1,165 Posts
Did you contact your dealer to see if Exmark would cover this under warranty??? There is no way an 08 mower should need a belt. I have a 2000 LazerHp that has 2500 hrs. I have replaced the deck belt 1 time and the hydro belt 3 times.
 

·
Registered
Joined
·
2,306 Posts
And this is not under warranty?
 

·
Registered
Joined
·
10,525 Posts
Discussion Starter · #10 ·
Yes it was under warrenty, didn't mean for it to sound like it wasn't.
Its just that it was so aggrivating.
Kajun, actually I am fairly easy on my mower, can't afford to break it, I am solo with only the one mower.
 

·
Registered
Joined
·
17,407 Posts
So why is this a warranty item......if a belt breaks for whatever reasons and cuts those wires, it is covered by warranty? That is a good company others probably would not cover it. Now maybe they routed the wires incorrectly when they did the engine work, but I have seen them cut when every thing was correctly routed.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top