Echo Blower no full throttle... carb?

Discussion in 'Mechanic and Repair' started by Snyderserv5060, Mar 27, 2007.

  1. Snyderserv5060

    Snyderserv5060 LawnSite Member
    Messages: 194

    I have an Echo 751 backpack blower. Bought last year so its got low hours and all to date. Had it out over the winter because one day we had a lame powder snow that was easier to literally blow off the driveway then shovel (it ran fine here)

    Had it out a month or so back and cleaned the driveway from all the misc leaves and debris, here it ran fine as well.

    Put it away for a month (in the shed) got it out the other day and filled it up with gas. I go to run it this weekend and it will not go full throttle. It just cuts out when you attempt to even when warmed up. I then replaced the air filter, gas, and spark plug (OEM parts). It still wont go full throttle.

    My feeling is somehow moisture got in the carb or in the gas that I was unaware of and thus causing carb problems. Anyone want to guess before I go ordering a new carb? Or is it worth pulling it off and trying to thoroughly clean it. Im skeptic with these little carbs tho as while its not cost effective its easier to just toss the old one and get a new one.

    Thanks for any advice.
  2. Raven386

    Raven386 LawnSite Silver Member
    from CT
    Messages: 2,169

    mines doing the same thing. my guess is the carb. but im not a mechanic so i dont know. i have to bring mine in one of these days. kind of need it for spring clean-ups.
  3. John Luttrell

    John Luttrell LawnSite Member
    Messages: 27

    Check the exhaust screen to make sure it's not blocked with carbon.
  4. Snyderserv5060

    Snyderserv5060 LawnSite Member
    Messages: 194

    Good call, I forgot the new emissions controls make that a problem sometimes. I will check that before I order a carb, if not i'll just order the carb.

  5. ed2hess

    ed2hess LawnSite Fanatic
    Messages: 14,596

    You did change the gas filter? I dont' know why you think it is a carb....for one thing most of these later models have an adjustment on them an that should be tried first. The adjusting screw is covered with a cap that you have to get out with a pick. The you have to grind a small screwdriver down so it will go into the opening. I guess you are hoping spark arrestor.
  6. Snyderserv5060

    Snyderserv5060 LawnSite Member
    Messages: 194

    Yes I changed the fuel filter as well.

    I think carb because... A worker of mine left a gas can out in the rain last season and then used it. The trimmer that the gas was used in would run but not full throttle just like this unit is doing now. I spent a while trying to get it working right and then swapped out the carb. Once I did this it ran perfect! The ignition parts are new(er) and again the unit worked a bit back.

    The carb ended up being $32 at my cost (oem walbro) so im going to try and swap it out just incase its the problem. Cant seem to think of much else, other then the muffler screen, that would cause this problem.

  7. nobagger

    nobagger LawnSite Gold Member
    from Pa
    Messages: 3,065

    Echo has a lot of carb problems, We had a trimmer x2 and a blower in the shop for no power, carb every time.
  8. topsites

    topsites LawnSite Fanatic
    Messages: 21,653

    An ailing coil will do it also, these should be under lifetime but you'll need to check the manual and likely it will be like pulling teeth to get warranty service.
  9. Snyderserv5060

    Snyderserv5060 LawnSite Member
    Messages: 194

    Verdict, the carb...

    Replaced it today and it runs great! Should have complained and tried to get it covered under warrenty since its less then a year old but for $30 it was not worth the wait and hassle of it.

    Thanks for you input.

Share This Page