• Online Events For Landscapers!
    With GIE+EXPO cancelled, virtual education and product launches are filling up the fall. Check out dates for Caterpillar, Exmark, NALP, and more. Click here to learn more.

Echo GT2000 problem

seawolf

LawnSite Member
I have an Echo GT2000 trimmer that I use for my small part-time residental lawn mowing service. Everytime after I use it, I have an oily residue that runs out the muffler and then across the back of the unit and down the gas tank. My oil-gas mix is correct. I replace the air filter, spark plug and gas filter each spring. My Echo dealer advised me to run the unit at full throttle- that didn't work. He adjusted the carb., which also didn't work. He told me to bring it in and he would take a closer look at it. Has anyone experienced the same problem, and if so, what was the problem?

Thanks.

 

Charles

Moderator, Friend, Angel
Location
South East
The problem is that you are paying attention to it. Long as it is doing its job. I ignore it. Everyone of them I have has done that
 

cutntrim

LawnSite Senior Member
Location
southern ontario
Charles is right. We've got 4 echos and they all excrete an oily residue to one degree or another, and they all work fine. Back when we used Homelites they did the same thing. As long as it's running fine don't worry about it.
 

turnkey

LawnSite Member
Location
fort ann ny
i have a 2100 that does the same thing..dealer adjusted the carb but still leaks the fuel,he then called echo and they told him that it has a "quad jet carb" and it must be run at full throttle..this seems to work so far!!!!!!
 
Top