Exmark Blade engagement HELP ASAP

Discussion in 'Lawn Mowing' started by jpp, Nov 28, 2004.

  1. jpp

    jpp LawnSite Silver Member
    Messages: 2,131

    OK, I used my lazer all day yesterday no problems. Today I start it up go to engage the blades and nothing. NO clicking or nothing. Shut the mower down engage blade switch tried to start nothing. Which that should be that way. Disengage blades start mower up and tried to engage blades same thing nothing. Cleaned all connections checked fueses. Is this a bad switch or blade clutch gone out. Any help would be appreciated. Thanks.

    Thank you in advance for any help


    Messages: 22

    check the wires underneith the machine that go to the switch, had a simialar problem with my torro, also check the fuses. something is short circuting.
  3. jpp

    jpp LawnSite Silver Member
    Messages: 2,131

    Did it check all connections are tight and fuses are good. Going to the garage to keep look again.
  4. Travis Followell

    Travis Followell LawnSite Silver Member
    from KY
    Messages: 2,206

    Check to see if your getting power to the switch and if you are see if its going to the electric clutch. If power is getting to the switch and not the clutch then the switch is most likely your problem.
  5. o-so-n-so

    o-so-n-so LawnSite Bronze Member
    from Alabama
    Messages: 1,218

    check belt...........if the belt is not on...the clutch will engage but you wont here it if the engine is running.

    set in seat-turn on switch (don't crank) and engage clutch-listen for the click.

    Don't get them fingers in there while checking....bad things will happen.

    good luck............
  6. jpp

    jpp LawnSite Silver Member
    Messages: 2,131

    Ok here is what i did. Went out started it up.It is running engage blade switch no blades but it died like it was supposed to do. Got back on started it up and engage blades no blades running though.Going back out will check on some of the other things
  7. Jackman

    Jackman LawnSite Member
    from Zone
    Messages: 231

    Sounds like the PTO, thats how it was on my Lazer...... Put a test light at the PTO connection and with the key on, engine off and the blade switch ingaged see if you have power to the connection...... If you have power at the PTO connection then your PTO is bad..... If you have no power at the PTO connection then check your safteys and the PTO switch it self..... Good Luck.....
  8. YardPro

    YardPro LawnSite Gold Member
    Messages: 3,570

    the swithc, or a saptery switch is most likely the culprit.

    use an ohm meter to check the switch first, they are a common problem
  9. Fantasy Lawns

    Fantasy Lawns LawnSite Bronze Member
    Messages: 1,912

    I may be wrong but if I remember correct atleast on my 2003 Lazer the PTO had a factory update as the same thing happen to mine when new .....went to the dealer n the switched it out ....diffenently something with the PTO
  10. jpp

    jpp LawnSite Silver Member
    Messages: 2,131

    I have power to the pto just ran a check to it. Now even if the pto is bad when I engage it without me being on the seat does it still die. I would assume so because it is still getting power but I don't want to assume. I don't have a pto handy or I would have swithced it out already. Going back outside to check on one more thing.

Share This Page