• Landscape Lighting Design: Bright Ideas
    With outdoor spaces more popular than ever, lighting these landscapes may be your next opportunity. Click here to learn more.

Exmark mower problems

solarscapes

LawnSite Member
Location
Cartersville, Ga
I have a 44" ztr. The right side going in reverse does not seem to work very well, and going foward seems to be jumpy. Any solutions. Also have 52" walk behind that seem to be not getting enough air. Replace both filters, but still have problem. Maybe carb. problem?
 

John Gamba

LawnSite Fanatic
Location
ct
Originally posted by solarscapes
I have a 44" ztr. The right side going in reverse does not seem to work very well, and going foward seems to be jumpy. Any solutions. Also have 52" walk behind that seem to be not getting enough air. Replace both filters, but still have problem. Maybe carb. problem?
Rider Could be Damper?
 

xcopterdoc

LawnSite Senior Member
Location
Parkton NC
Have you changed the hydro filter on the ztr lately? Any hyd seeps? The dampners on the steering will make the controls jumpy for sure, but shouldnt effect the flow of power from fwd to reverse. Both should be equal. Air in the system will make any hyd system do funky things, thats why I asked about the hyd filter and seeps. As for the WB, what lead you to the assumption that it isnt getting enough air? Please be more specific.
 
OP
S

solarscapes

LawnSite Member
Location
Cartersville, Ga
Originally posted by xcopterdoc
Have you changed the hydro filter on the ztr lately? Any hyd seeps? The dampners on the steering will make the controls jumpy for sure, but shouldnt effect the flow of power from fwd to reverse. Both should be equal. Air in the system will make any hyd system do funky things, thats why I asked about the hyd filter and seeps. As for the WB, what lead you to the assumption that it isnt getting enough air? Please be more specific.
While running with pto engaged, engine bogs down and shuts off. If I pull the choke the engine will maintain idle, but only happens when pto is engaged.
 

xcopterdoc

LawnSite Senior Member
Location
Parkton NC
You have a valve problem. Either the valve clearance is off or you have a bent pushrod.
 
Top