1. Can’t make it to the GIE+EXPO 2017?
    LawnSite brings the trade show floor to your fingertips with our new GIE+EXPO 2017 Sneak Peek video series debuting now in the Lawn Mowing forum.

    Dismiss Notice

exmark not running right

Discussion in 'Mechanic and Repair' started by robby, Jun 30, 2007.

  1. robby

    robby LawnSite Member
    Messages: 89

    I have a wb Exmark TT with the 17 hp kawasaki. For about a week now its been running poorly, sputtering off and on and just not running smooth. Ive changed plugs and the fuel filter with no success. Anyone with a guess of what else it could be?
     
  2. khouse

    khouse LawnSite Bronze Member
    Messages: 1,465

    It sounds like the same old dirty carb and/or fuel issue. Clean fuel tank and lines. Replace fuel filter. Tear down carb and blow it out with compressed air.
     
  3. robby

    robby LawnSite Member
    Messages: 89

    Is it possible that it could be related to the safety feature on mowers that kills the engine when handle is released? Not sure what its called, but its a little small box with a button on the top located in the middle underneath the handlebars. Could that cause similar problems if something stopped functioning there?
     
  4. Albery's Lawn & Tractor

    Albery's Lawn & Tractor LawnSite Bronze Member
    Messages: 1,674

    If its not running smooth then its a carb issue. Take it apart, clean it, and rebuild it, or take it to someone who knows what there doing it let them do it. If a safety switch is bad then the machine wouldn't start/run.
     

Share This Page