Exmark zturn power drain

MAX G MILLER

LawnSite Member
Location
Terrell TX
I have a 60 exmark that drains the battery after several days of sitting. I have disconnected all devices except for the 543316 module. Ishow power still draining until I pull the carb solenoid. Then the power drain goes way down. Is the module bad
 

Breezmeister

LawnSite Silver Member
Location
South Jersey
I have a 60 exmark that drains the battery after several days of sitting. I have disconnected all devices except for the 543316 module. Ishow power still draining until I pull the carb solenoid. Then the power drain goes way down. Is the module bad

I doubt it. Is your batter more then 2 years old ? If it is, then I would suspect the battery is not holding a charge. How many times have you had to jump it ?

You need to verify that. You can take your battery to most auto parts stores and have them test it for free.

If you want more help, then go here
.
 
OP
M

MAX G MILLER

LawnSite Member
Location
Terrell TX
I doubt it. Is your batter more then 2 years old ? If it is, then I would suspect the battery is not holding a charge. How many times have you had to jump it ?

You need to verify that. You can take your battery to most auto parts stores and have them test it for free.

If you want more help, then go here
.
New battery
 

nw883

LawnSite Member
Location
TN
Maybe check ignition switch as the solenoid should be powered on when the ignition is on.
This would be the first thing I'd check. See if the ignition switch is actually cutting off power to the module with the ignition switch off. I'm assuming that module gets input from all the safety/interlock switches which then supplies power to the carb solenoid and starter relay. The residential Toro's use a similar brake control module which are notorious for failing usually due to water intrusion at the connectors and creating a short.
 
OP
M

MAX G MILLER

LawnSite Member
Location
Terrell TX
This is a commercial zmaster I have unplugged the ignition switch the time clock, alternator regulator. The power draw quits when I removed the solenoid wire or unplug the module.
 

JoeRagMan

LawnSite Senior Member
Location
Near TMI
Okay Max, a few questions; how are you measuring battery drain? Did you have the battery tested? Do you have a model and serial number for your mower so we can access a wiring diagram to help you? I'm thinking there is a relay somewhere that should energize several components when the key is in the run position. With the key off, that relay is stuck in the closed position causing the battery to drain. Just a guess on my part...
 

Top