Ferris IS3200Z PTO problems

CMS829

LawnSite Member
Hey all. Working on my neighbors Ferris, which he said just shut down on him completely while mowing. Trying to do him a favor, but this is the first time I am trouble shooting a ferris.

I have figured out that the PTO fuse is blowing. So I took a look at the PTO and the anti rotation bolt was bent badly. Figured that was the issue, replaced it, and still doing the same thing. The starter engages but wont turn the engine over. I tested the PTO switch, and it is working as it should.

If I disconnect the PTO anti Rotation bolt, the mower fires right up and runs great. The blades spin freely by hand when not running.

I tested the OHMs of the PTO and I am getting an OL (open) reading on the coil.

I have to assume this is the issue. That the coil inside the PTO is shot. Would I be correct? Only repair is a new coil and or complete PTO?
 

hal

LawnSite Fanatic
Location
Georgia
So the clutch is spinning around with the engine? What about the wires to the clutch?
 
OP
C

CMS829

LawnSite Member
Not initially, no. to see if it would fire up with the clutch disconnected, I removed the wiring harness. It then fires up and the clutch tests open.
 
OP
C

CMS829

LawnSite Member
Spoke with Warner, the MFG of the PTO. And they confirmed my suspicion. According to him it sounds like the clutch was slipping, which basically melted the components and fused them together, which then shorted out the internal coil.

Funny thing (sad thing) is that the mower barely has 100 hours on it. My neighbors dealer is going to come pick it up and it should be covered under warranty.
 

Top