1. Is Landscaping An “Essential Business” In Your Region?
    Read the timely article from Turf addressing this question. Click here to learn more.

    COVID-19 Safety Procedures For Landscapers
    As you are working out in the field, maximize safety for you, your crews, and customers. Click here to learn more.

    Dismiss Notice

Ferris SRS Z2 hydro and parking brake

Discussion in 'Mechanic and Repair' started by EricC, Mar 15, 2020.

  1. EricC

    EricC LawnSite Senior Member
    Messages: 670

    I have a 2017 Ferris Z2 52" with fx730efi and was sitting at 97 hours to finish my first summer at home. Changed hydro oil and filters today and when I was done, i noticed that with the parking brake on, my right stick would move and the left was locked out like it should be.

    I know the sticks are supposed to be locked when parking brake is on, i have no idea what I did. The parking brake works when engaged. With the machine off and the hydros bypassed i can turn the wheel with the parking brake off, and engaged i can't.

    So I start it back up, with brake engaged, i can hear the hydro whine when I move the stick, but the wheel doesn't budge.

    It has been purged of air and it acts normally driving it around. rode it around for 5 minutes or so, everything seemed perfectly normal, except that parking brake and the right stick still moving when engaged and engine running or off?

    On a side note, I had NO filter guards on it when I went to change the oil. pretty sure those were supposed to be there LOL. I never took them off.
     
  2. OP
    OP
    EricC

    EricC LawnSite Senior Member
    Messages: 670

    anyone?
     
  3. snapper

    snapper LawnSite Senior Member
    Messages: 418

    look under the console and work the parking brake and see what is not working. on mine there is a lever on each side with a bolt sticking out that engages a notch in the control handles and locks them in neutral.
     
    Breezmeister and EricC like this.
  4. OP
    OP
    EricC

    EricC LawnSite Senior Member
    Messages: 670

    Found it :)

    The bolt fell down and believe it or not I found both bolt and nut. There it is where it's supposed to be on the left side, and missing on the right. I don't know if it's a coincidence or not, but the right side is the one i'm having troubles with :)

    I did operate it before and everything was moving in unison side to side, but I missed the bolt swinging into place. probably because it was missing and didn't notice it on the left.

    Thanks Snapper!
     

Share This Page