• CA Lessons: Landscaping To Reduce Wildfire Risk
    While there are no ways to fireproof a property, there are strategies to design and maintain landscapes for reduced vulnerability. Click here to learn more.

fisher drops&driveshaft wobbles

sam c

LawnSite Member
Location
Plaistow NH
I recently bought a 91 f350 diesel with a 9' fisher (not minute mount) with a belt driven pump.when the fluid is hot the engine has to be raced quite a bit to raise the plow,also if the plow is raised and the control lever is held in the raise position at idle the plow will drop unless the engine is raced up. when the fluid is cold the plow seems to work fine in fact i can see the pressure line from the pump to the valve body flex with pressure when a cylinder bottoms out! any suggestions?
also on the same truck i have found there to be a lot of play in the double ujoint assy. on the front drive shaft the joints seem fine it appears to be a bearing (or lack there of) of sorts between the two joints that is loose. would you advise me to replace or rebuild this. the truck has 150k mi.and an e4od auto trans. i have hade four trucks similar to this one and never these problems.
thanks in advance!
 

9FT.PILES

Banned
Location
PHILA.PA.
Again no need to quote the entire post.
Dino

IS THIS TRUCK NEW? SOUNDS LIKE THE DEALERS PROBLEM! SORRY I COULD NOT E-MAIL U THIER SERVER MUST BE DOWN. 9FT PILES. 11:10 PM,01/04/01

[Edited by plowking35 on 01-05-2001 at 06:49 AM]
 
OP
sam c

sam c

LawnSite Member
Location
Plaistow NH
it`s new to me but from a wholesale "as is" used truck dealer.
 

FIREMAN

LawnSite Senior Member
Location
n.j.
SOUNDS LIKE A STICKY VALVE/ SOLENOID SOMEWHERE IN THE CONTROL VALVING..AS FAR AS NEEDING TO REV UP FOR RAISING MAYBE FLUID IS REALLY OLD, DIRTY OR THE WRONG TYPE...
 

plowking35

LawnSite Bronze Member
Location
S.E. CT
On the valve body of the fisher, there are two cables one goes to a single spool valve, the other to a double spool valve.
Find the single spool valve, that is the lift and drop valve.You need to adjust that cable, sounds like it leaves the lift valve open just a hair, causeing the plow to drop.
They have a threaded cable with double nuts, move those nuts in or out to achieve the deesired adjustment.
Sorry cant help you with the ford problem, we are chevy people.
Dino
 

Deere John

LawnSite Senior Member
Satisfactory plow performance with cold fluid contrasted against poor performance with warm fluid is an indication of a worn pump. Thin oil bypasses through the not-so-close-tolerances-anymore of the pump. There are many Fisher users here who can offer alternatives for fixing that problem (I don't have any Fisher experience)

Secondly, the CV joint has a grease fitting in it that needs a needle-nose adapter to grease. This probably was not done, so you have a worn out joint on your hands as well. Do not delay in changing this if you use the front drive. In my younger days, we did, and the joint let go and took a chunk of the transmission housing with it. A $150 bill went to an $1,800 bill pretty quick. Good luck with your truck and business.
 

Alan

Member
Originally posted by sam c
I recently bought a 91 f350 diesel with a 9' fisher (not minute mount) with a belt driven pump.
Pretty easy to see it's not a new truck,, can't remember the last time I saw a new 91 anything,, was probably back in 91.

Damn illiterate experts!

Now, as for a serious answer to the original question, I'd tend to think the pump is getting a bit loose. Tolerances are too sloppy to pump warm (and thin) oil.

Dino, if it's dropping against the pump in the up valve position I'd nto think it's bad adjustment

[Edited by ChucksChevyPages on 01-05-2001 at 08:02 PM]
 

DaveO

LawnSite Member
Location
N. Dighton MA.
Sam C,

I agree with Deere John/Alan.

Had the same problem with my Fisher plow. When hot it would not lift the blade until engine rpm was increased. My pump was old/tired, replacing it cured the problem. You could flush the fluid, and check the cable adjust. But my money is on the pump.

Dave
 

plowking35

LawnSite Bronze Member
Location
S.E. CT
I to am illiterate, I missed the point regarding the stcik in the up position, still causing the ram to creep down unless the engin was raced. I agree new pump.
Dino
 

nsmilligan

LawnSite Member
Location
Nova Scotia
Just an after thought,I agree it's likely a worn pump, but what kind of fluid are you using? Fisher fluid is designed for use in under the hood pumps at high temps, and electro-hydro pumps at minus 20. If it has the wrong fluid it could also act the same way.

Bill
 
Top