Gravely Hydro Pro Hydraulics

2muchgrass

LawnSite Member
Location
Perryville, MD
I picked up this Gravely Hydro Pro (Model and year unknown) and was going to get rid of it but it's kind of grown on me. It cuts and runs nice but the hydraulics are giving me fits. I should have left well enough alone as it was steering fine except when it was cold. It was a little hinky for the first few minutes. But I couldn't leave it alone and tried to adjust it so the hand levers were a little closer to the grips. It all went downhill from there.
First, the overall speed went WAY down. Then I lost reverse. Then it would either want to veer one way or the other.
Right now it seems to be steering straight but the speed is still gone and I have no reverse.
Can someone shed a little light on the problem?
The label with the model and serial number is gone.
There are pictures over on this thread.
http://www.lawnsite.com/showthread.php?t=358753&highlight=Gravely+Hydro+Pro
I posted my problem over there but it was an old thread so I guess nobody is reading it.
 
OP
2

2muchgrass

LawnSite Member
Location
Perryville, MD
It might be helpful if I knew what model it was. As it stands now the speed is still gone and it wants to veer to the left. I have some reverse though not like it was. I don't see how it could help but I'm going out to get some hydraulic oil and a filter. I don't even know what kind of oil to buy.
The machine cuts really well and is (was) very maneuverable. I'd like to be able to use it again.
Hope someone can point us in the right direction.
By the way, my name is Andy, also.
 

Top