Gravely only runs when key is held to "start"

Discussion in 'Mechanic and Repair' started by goatchay, Sep 21, 2009.

  1. goatchay

    goatchay LawnSite Member
    Messages: 5

    Hi to all,
    I apologize for posting this in a commercial forum, but I am having no luck obtaining and answer anywhere else. I just purchased a used Gravely PM320 for my dad. I used it the day I bought it and cut 3 acres, it ran flawlessly.

    I then parked it (2 days ago) and went to move it today. It starts up fine but only runs as long as I hold the key to the "start" position. As soon as it is released to "run" it kills. All of the safeties seem to be working properly (seat, parking brake, PTO, neutral). Oil and fuel levels are fine. It ran perfectly the last time I used it.

    I do notice that when you turn the key to the "start" position ALL THE WAY, that the motor doesn't turn over. I have to slowly turn the key and it bumps the start a little before the key is turned all the way. If you go past this point it won't turn over at all. It's almost like you have to find the sweet spot in the range of the key, if that makes any sense.

    The first day I ran the mower, the key did not behave in this way. A general look around and things seem to be fine other than that (fuel looks good in the fuel filter, according to the previous owner both coil packs were changed within the last year, plug cables look fine, etc.).

    Any help would be greatly appreciated, I hate to give my dad a mower that he needs to bring someplace to have repaired right off the bat.

    Does this point to a problem with the ignition switch itself? I think the manual has a continuity diagram for the switch but I don't have a meter at the moment. Many thanks in advance,

  2. Restrorob

    Restrorob LawnSite Fanatic
    Messages: 11,029


    Just replace the ignition switch and be done with it, Make sure there's no rust/corrosion on the "B" post on the old switch. If there is that connector inside the harness plug will be rusted/corroded as well and may need replacing.
  3. goatchay

    goatchay LawnSite Member
    Messages: 5

    Hi Restrorob,
    Thanks for the response. I appreciate it. I thought that might be the first logical thing to do, I was just puzzled as to why it worked perfectly fine the last time I operated the mower and just suddenly is defective.

    I initially was leaning towards a fuel problem, but that wouldn't explain why it dies after the key is released. I think that the motor might have an electrically activated inlet needle? on the carb and thought that could possibly be the problem. I'm not familiar with anything electric on carbs, but I thought I saw a wire connected somewhere near the bowl. I have to take a closer look tomorrow, I ran out of daylight today. BW, it is a Kohler 27 hp motor. I do hope it is as simple as the switch. Thanks again,
  4. goatchay

    goatchay LawnSite Member
    Messages: 5

    Ok, after some more research through the forums, I'm concerned that I may have shut down the engine improperly. It is a Kohler Command 27hp. It has a fuel shut off solenoid, which I have never heard of. I guess all of the equipment that I'm used to being around is too old to have it.

    According to the manual, the mower should be shut down at half idle or greater. I reduced the throttle to it's minumum and let the engine run for a few minutes to cool down before I shut it off with the key. Just an old habit I guess. But apparently this was the complete opposite of what I should have done. I had never heard of intentionally shutting down a mower at higher rpm, thought it would cause it to backfire.

    Here is a quote from another thread from a few months ago, (attributed to S DIAMOND)

    I did not experience a backfire when I shut the mower down a few days ago, but I did today when I was attempting to start it. I think I understand the point of the shut off solenoid, but could not shutting it down as per Kohler recommendation cause trouble in re-starting it?

    Is it possible or advisable to remove the shut off solenoid? Thanks,
  5. goatchay

    goatchay LawnSite Member
    Messages: 5

    Well, still looking around and finding more threads that may corroborate the fuel solenoid theory. Here is a thread that seems to describe what is happening with my mower:

    " Default Re: 755 hard to start, won't idle
    That solenoid is the fuel shutoff. It has two electrical coils in it. The first one has power while the key is ON, the second only has power while the key is turned to START. The first one only has enough power to keep the solenoid engaged. It does not have power to pull in the solenoid from an OFF condition. The second coil, on during START, is what will pull in the solenoid. The first coil will then keep the solenoid engaged after the tractor is started. When the key is turned OFF, it will disengage and shut off the fuel. This system prevents fuel flow to the cylinders each start sequence until the key is turned past ON, to START. Sounds like the hold coil is not working. Watch the operation of the solenoid during start and run. It should stay engaged until the key is turned back to OFF. BTW, my 755 has never idled smoothly at low rpm. I just let it idle slightly faster than minimum.

    Default Re: 755 hard to start, won't idle
    You are correct that the white wire from the starter is the connection to activate that second coil. Sounds like that part is working OK. The red wire on the solenoid connector provides voltage to the first coil when the key is ON. That red wire runs to a connector just above the coil. If you have a voltmeter you should be able to check for 12 volts on the back side on the connector where the pink and yellow wires go in to make the connection to the red wire on the other side. If that is OK then the coil is bad. If the voltage is not OK, then you not only have no power to the coil, but you also have no power to the thermo-start controller that activates the glow plugs and the preheat dash light. Does that light work OK? If not it would be a first indication of no voltage to the coil.

    When the first coil is not working, it will immediately shut down the engine when the key is returned from start to run. Does the engine act like it is starting and so you return the key to the run position?

    In your first post you said it would run if you held in the solenoid. Is that still the case? If so, then the problem is definitely the coil. Sorry to hear about your severe vibration. I have no answer for that.

    Default Re: 755 hard to start, won't idle
    Probably the best way to say it is, with a bad solenoid as soon as you take the key off START position the engine will not run. Does the engine crank and crank with nothing that seems to catch? Or is there a sense of starting and so you let off the START? You could of course have an additional issue with fuel, but I would solve the solenoid issue first and go from there.


    I think I will push the plunger in manually and then turn the key to "ON", and it should stay retracted, correct? This sure seems like a good way to complicate an engine more than necessary, I've never seen a carb with one of these. I'll post an update tomorrow. Thanks for all of the input.
  6. VegetiveSteam

    VegetiveSteam LawnSite Senior Member
    Messages: 296

    I have a questions or suggestion on something to check but please do NOT take it as me trying to say the fuel solenoid is faulty. The only reason I am going to mention the fuel solenoid is because it is an easy place to take a voltage reading. Unplug the wire that goes to the fuel solenoid. Turn the key to the on/run position. Take a voltmeter and check the voltage on the wire that feeds the fuel solenoid. You should be reading battery voltage. If you read zero then you either have a faulty ignition switch as Rob pointed out or you have a bad diode in the circuit that feeds power to the fuel solenoid and spark advance module. Do this one check and reply back with your findings. Also shutting it down improperly can cause problems but only running with the key in the start position is not one of them.
  7. LouisianaLawnboy

    LouisianaLawnboy LawnSite Silver Member
    Messages: 2,199

    Things happen, just replace the switch 40.00.
    Posted via Mobile Device
  8. goatchay

    goatchay LawnSite Member
    Messages: 5

    Hi to all,
    I just wanted to update the status of the Gravely. Sorry to take so long, it's been raining hard everyday here in La. and I haven't been able to trouble shoot the mower any further until today.

    And the verdict is: It was the switch as everyone had suggested. Thankfully. I guess I was guilty of not keeping it simple once I started thinking about the fuel solenoid. Thanks to everyone for sending me in the right direction, I wanted to make sure the mower was running OK for my dad before I left town.

    Thanks again,

Share This Page