hydraulic problem

Discussion in 'Mechanic and Repair' started by l555, Jan 11, 2007.

  1. l555

    l555 LawnSite Member
    Messages: 3

    i am a new skid steer owner/user. i just moved and was getting my machine out of the trailer and the bucket would not work. i was able to get the machine out of the trailer, but right after i got it out, the drive stopped working also. the "hydraulic charge" light came on (which i have never seen on before). it went of briefly and i was able to move it (still no bucket capability), then it came back on again and i lost all control.

    the problem..?
    when i bought the machine i noticed the hydraulic fluid was a milky white-ish color. not knowing any better, i just thought it was a special fluid. i used the machine for a few months around the house with absolutely no problems. as mentioned, i moved and now it's not working.
    any suggestions?

    thanks in advance!
  2. mohopper

    mohopper LawnSite Member
    Messages: 14

    try new fluid and filter first. saw this a thousand times at the deere dealer i worked at.
  3. l555

    l555 LawnSite Member
    Messages: 3

    alright..that's what i was going to try unless someone told me otherwise.
    now i just gotta get info on how/where to change it out.
  4. Restrorob

    Restrorob LawnSite Fanatic
    Messages: 11,029

    If changing the fluid does not correct the problem check the low pressure switch which should be screwed into the hydro filter holder, I had one take a dump in ours that shut down all controls.
  5. l555

    l555 LawnSite Member
    Messages: 3

    alright..sounds good. hopefully the pump isn't shot.

Share This Page